aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/xisp/Makefile21
-rw-r--r--net/xisp/distinfo4
-rw-r--r--net/xisp/files/patch-Makefile13
-rw-r--r--net/xisp/files/patch-Makefile.nodes86
-rw-r--r--net/xisp/files/patch-warn.c8
-rw-r--r--net/xisp/files/patch-xisp.c11
-rw-r--r--net/xisp/files/patch-xispterm.c11
-rw-r--r--net/xisp/pkg-plist2
8 files changed, 25 insertions, 131 deletions
diff --git a/net/xisp/Makefile b/net/xisp/Makefile
index 26fcfed5f805..3813bc1dee6f 100644
--- a/net/xisp/Makefile
+++ b/net/xisp/Makefile
@@ -1,29 +1,24 @@
# New ports collection makefile for: xisp
# Date created: June 24, 1999
-# Whom: morishim@cig.mot.com
+# Whom: tm@onepost.net
#
# $FreeBSD$
#
PORTNAME= xisp
-PORTVERSION= 2.6
+PORTVERSION= 2.7
CATEGORIES= net
-MASTER_SITES= http://www.ml-search.com/xisp/distfiles/
-DISTFILES= xisp-2.6-noufc.tar.gz \
- xisp-2.6-freebsd-patch.tar.gz
+MASTER_SITES= http://xisp.hellug.gr/release/
-MAINTAINER= morishim@cig.mot.com
+PATCH_SITES= http://www.ml-search.com/xisp/distfiles/
+PATCHFILES= xisp-2.7-freebsd-patch-20030126.gz
+
+MAINTAINER= tm@onepost.net
LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
USE_XPM= yes
-WRKSRC= ${WRKDIR}/xisp-2.6
+
MAN1= xisp.1
-HAS_CONFIGURE= yes
-.if defined(WITH_DES)
-CONFIGURE_ENV= USE_DESLIB="yes"
-.else
-CONFIGURE_ENV= USE_DESLIB="no"
-.endif
.include <bsd.port.mk>
diff --git a/net/xisp/distinfo b/net/xisp/distinfo
index 8807875e0c6c..1cc39fe30203 100644
--- a/net/xisp/distinfo
+++ b/net/xisp/distinfo
@@ -1,2 +1,2 @@
-MD5 (xisp-2.6-noufc.tar.gz) = bb06960ab5eacb669c9bc788c18b8103
-MD5 (xisp-2.6-freebsd-patch.tar.gz) = b65096edb77490372472ffbd71fcf197
+MD5 (xisp-2.7.tar.gz) = cf942ff8f19f05a5e67120723a45e1f9
+MD5 (xisp-2.7-freebsd-patch-20030126.gz) = c514bd6c309a5a382e1c556b7a09c185
diff --git a/net/xisp/files/patch-Makefile b/net/xisp/files/patch-Makefile
new file mode 100644
index 000000000000..b1861b2b67fb
--- /dev/null
+++ b/net/xisp/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Mon Feb 3 04:59:04 2003
++++ Makefile Mon Feb 3 04:59:28 2003
+@@ -13,8 +13,8 @@
+ #=====================================================================
+ #
+ CC = gcc
+-PREFIX = /usr/local
+-X11PREFIX = /usr/X11R6
++PREFIX = ${LOCALBASE}
++X11PREFIX = ${X11BASE}
+ INCX11 = $(X11PREFIX)/include
+ LIBX11 = $(X11PREFIX)/lib
+ INCFORMS = $(X11PREFIX)/include/X11
diff --git a/net/xisp/files/patch-Makefile.nodes b/net/xisp/files/patch-Makefile.nodes
deleted file mode 100644
index d69670accece..000000000000
--- a/net/xisp/files/patch-Makefile.nodes
+++ /dev/null
@@ -1,86 +0,0 @@
---- Makefile.nodes.orig Sun Aug 8 06:43:28 1999
-+++ Makefile.nodes Wed Nov 27 04:43:56 2002
-@@ -201,10 +201,9 @@
- GROUP = dialer
- CHAT_PATH = /usr/bin
- PPPD_PATH = /usr/sbin
--GCCFLAGS = -Wall -O
- EXTRALIBS =
- LINKX11 = -Wl,-R$(LIBX11)
--LINKFORMS = -L$(LIBFORMS) -lxforms
-+LINKFORMS = -L$(LIBFORMS) -lforms
- INSTALL = /usr/bin/install
- MODEM_DEV = cuaa0
- MODEM_DEVS = cuaa0 cuaa1 cuaa2 cuaa3
-@@ -238,7 +237,7 @@
- #
- # gcc option flags
- #------------------
--GCCOPTS = $(GCCFLAGS) $(DEFINES) $(EXTRADEFS)
-+GCCOPTS = $(CFLAGS) $(DEFINES) $(EXTRADEFS)
- #
- #=====================================================================
- # You shouldn't need to edit anything below this line |
-@@ -247,49 +246,49 @@
- all: xisp xispdial xisprccv xispterm xispid
-
- xisp: xisp.o nodes.o warn.o network.o rcio.o logs.o
-- gcc $(LINKX11) -o xisp xisp.o nodes.o warn.o network.o rcio.o logs.o $(EXTRALIBS) -L$(LIBX11) $(LINKFORMS) -lXpm -lX11 -lm -lmd
-+ $(CC) $(LINKX11) -o xisp xisp.o nodes.o warn.o network.o rcio.o logs.o $(EXTRALIBS) -L$(LIBX11) $(LINKFORMS) -lXpm -lX11 -lm -lmd
-
- xisp.o: xisp.h xisp.c xisp.xpm version.h common.h pcode.h network.h rcio.h logs.h help.c peHelp.c excl.xpm
-- gcc $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -c xisp.c
-+ $(CC) $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -c xisp.c
-
- xisp.xpm:
- cp $(XPMIMAGE) xisp.xpm
-
- pcode.o: pcode.h pcode.c
-- gcc $(GCCOPTS) -c pcode.c
-+ $(CC) $(GCCOPTS) -c pcode.c
-
- nodes.o: pcode.h
-- gcc $(GCCOPTS) -c nodes.c
-+ $(CC) $(GCCOPTS) -c nodes.c
-
- warn.o:
-- gcc $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -c warn.c
-+ $(CC) $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -c warn.c
-
- nowarn.o:
-- gcc $(GCCOPTS) -c nowarn.c
-+ $(CC) $(GCCOPTS) -c nowarn.c
-
- network.o: network.h network.c
-- gcc $(GCCOPTS) -c network.c
-+ $(CC) $(GCCOPTS) -c network.c
-
- xispdial: xispdial.c common.h version.h
-- gcc $(GCCOPTS) -o xispdial xispdial.c
-+ $(CC) $(GCCOPTS) -o xispdial xispdial.c
-
- xisprccv: xisprccv.o nodes.o nowarn.o
- gcc -o xisprccv xisprccv.o nodes.o nowarn.o $(EXTRALIBS) -lm -lmd
-
- xisprccv.o: xisprccv.c common.h version.h pcode.h logs.h
-- gcc $(GCCOPTS) -c xisprccv.c
-+ $(CC) $(GCCOPTS) -c xisprccv.c
-
- xispterm: xispterm.h xispterm.c
-- gcc $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -o xispterm xispterm.c $(EXTRALIBS) -L$(LIBX11) $(LINKFORMS) -lX11 -lm
-+ $(CC) $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -o xispterm xispterm.c $(EXTRALIBS) -L$(LIBX11) $(LINKFORMS) -lX11 -lm
-
- rcio.o: rcio.h rcio.c common.h version.h
-- gcc $(GCCOPTS) -c rcio.c
-+ $(CC) $(GCCOPTS) -c rcio.c
-
- logs.o: logs.h logs.c version.h
-- gcc $(GCCOPTS) -c logs.c
-+ $(CC) $(GCCOPTS) -c logs.c
-
- xispid: xispid.c
-- gcc $(GCCOPTS) -o xispid xispid.c
-+ $(CC) $(GCCOPTS) -o xispid xispid.c
-
- install: xisp xispdial xisprccv xispterm xispid
- if [ ! -d $(DESTDIR)$(BINX11) ]; then $(INSTALL) -d $(DESTDIR)$(BINX11); fi
diff --git a/net/xisp/files/patch-warn.c b/net/xisp/files/patch-warn.c
deleted file mode 100644
index 3eeae44484b8..000000000000
--- a/net/xisp/files/patch-warn.c
+++ /dev/null
@@ -1,8 +0,0 @@
---- warn.c.orig Wed Nov 27 04:34:55 2002
-+++ warn.c Wed Nov 27 04:35:24 2002
-@@ -1,4 +1,4 @@
--#include <forms.h>
-+#include <X11/forms.h>
-
- /*
- * No DES information
diff --git a/net/xisp/files/patch-xisp.c b/net/xisp/files/patch-xisp.c
deleted file mode 100644
index 1286fff52fc4..000000000000
--- a/net/xisp/files/patch-xisp.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xisp.c.orig Wed Nov 27 04:36:07 2002
-+++ xisp.c Wed Nov 27 04:36:12 2002
-@@ -18,7 +18,7 @@
- For author contact information, look in the README file.
- */
-
--#include <forms.h>
-+#include <X11/forms.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <errno.h>
diff --git a/net/xisp/files/patch-xispterm.c b/net/xisp/files/patch-xispterm.c
deleted file mode 100644
index 55aba061dd06..000000000000
--- a/net/xisp/files/patch-xispterm.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xispterm.c.orig Wed Nov 27 04:35:03 2002
-+++ xispterm.c Wed Nov 27 04:35:08 2002
-@@ -18,7 +18,7 @@
- For author contact information, look in the README file.
- */
-
--#include <forms.h>
-+#include <X11/forms.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <varargs.h>
diff --git a/net/xisp/pkg-plist b/net/xisp/pkg-plist
index 2273b5a3de45..76853edfc0c2 100644
--- a/net/xisp/pkg-plist
+++ b/net/xisp/pkg-plist
@@ -1,11 +1,13 @@
@cwd /etc/ppp
ip-down
ip-up
+
@exec mkdir -p %D/peers
peers/xisp_cuaa0
peers/xisp_cuaa1
peers/xisp_cuaa2
peers/xisp_cuaa3
+peers/xisp_umodem
peers/xisp_dialer
@cwd /usr/X11R6
800'>2004-11-012-4/+4 * - After repocopy from polish/sms, update to 2.0.0pav2004-11-017-113/+20 * I, for one, welcome our new polish php_doc slaveport!edwin2004-10-212-0/+14 * - Update to 1.9.2mpav2004-09-0210-40/+106 * - Resign on maintainership of my FreeBSD portspav2004-09-023-3/+3 * Update to KDE 3.3lofi2004-08-319-23/+119 * Chase libaspell to aspell.16.thierry2004-08-291-2/+2 * Factor out all but one of the build switches of the KDE main module portslofi2004-08-116-9/+9 * Fix build with gcc-3.4krion2004-08-041-0/+2 * - Update to 2.0.3pav2004-07-225-3/+164 * - OpenSSL is special on FreeBSD, it's always there, and is not visiblepav2004-07-222-0/+11 * Apply a big libtool patch to allow porters to use the libtool installed bymarcus2004-07-101-1/+1 * - Update to 1.5pav2004-07-062-4/+4 * - Update to 0.3.9pav2004-07-034-10/+35 * Back out accidental modification.lofi2004-06-101-2/+1 * Update to version 3.2.3lofi2004-06-105-4/+19 * BROKEN: Checksum mismatchkris2004-05-211-0/+2 * - Update to 2.0.2pav2004-05-114-18/+11 * - Update to ekg-1.4.20040505pav2004-05-102-6/+13 * Oops. Forgot the language categories.lofi2004-05-079-9/+15 * Update to latest snapshot, to fix build problems on STABLEarved2004-05-033-11/+18 * Update to 0.3.8arved2004-04-294-58/+142 * Update to KDE 3.2.2lofi2004-04-204-40/+14 * Fix LATEST_LINK conflictsmaho2004-04-121-0/+1 * Chase the glib20 update, and bump all affected ports' PORTREVISIONs.marcus2004-04-051-0/+1 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+3 * - Update to 2.0pre8pav2004-04-025-36/+15 * SIZEify (maintainer timeout)trevor2004-03-315-0/+5 * Add tleenx2, a Gtk2 client for IM network tlen.plpav2004-03-305-0/+107 * Reorder those filesmat2004-03-211-2/+2 * Whoa there, boy, that's a mighty big commit y'all have there...ade2004-03-141-1/+1 * Update to KDE 3.2.1 / QT 3.3.1lofi2004-03-109-4/+61 * - Update to 2.0 pre7pav2004-03-036-27/+31 * - Update to version 20040212krion2004-02-252-2/+3 * - Fix Makefile logic: enter src/plugins/sound subdir when external sound pluginpav2004-02-182-4/+11 * BROKEN on 5.x: broken pkg-plistkris2004-02-181-0/+4 * - Try again in fixing the installpav2004-02-172-10/+9 * BROKEN on 5.x: install failskris2004-02-171-0/+4 * - Fix desktop iconpav2004-02-142-4/+5 * - Update to 0.3.7pav2004-02-145-454/+425 * - Update to 20040208 snapshotpav2004-02-142-4/+4 * Fix CATEGORIES.lofi2004-02-052-2/+2 * Update to KDE 3.2.0lofi2004-02-0515-56/+273 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-046-1/+6 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-045-10/+10 * Now gettext 0.12.1 is gettext-old.trevor2004-01-245-5/+5 * - Chase libraries because of new loudmouth versionkrion2004-01-231-1/+1 * - Update to version 2.0.p6krion2004-01-224-12/+20 * Add gnugadu 2.0 pre5 after repocopy from polish/gnugadu.pav2004-01-1610-159/+488 * - Update to 20040111pav2004-01-132-2/+2 * - Update to version 20031223krion2003-12-262-2/+2 * Add ispell in polish category.jmz2003-12-122-0/+24 * Chase libgadu shared library version.arved2003-11-191-1/+2 * Update to 1.4arved2003-11-193-8/+9 * OpenOffice -> OpenOffice.orgmaho2003-11-093-3/+3 * Update ekg to new version.jeh2003-11-092-3/+3 * Add OpenOffice.org 1.1 for polish languagemaho2003-11-092-0/+16 * Forgot to change Makefile s..maho2003-11-081-1/+1 * rename openoffice* to openoffice-1.0* accodingly (repo copy).maho2003-11-081-1/+1 * rename openoffice to openoffice-1.0 after repocopymaho2003-11-082-16/+1 * Add libtlen 20030721, backend for interoperability withkrion2003-10-096-0/+95 * - Update to version 0.3.4krion2003-10-064-13/+20 * - Update to version 20031003krion2003-10-063-49/+14 * Add trf 0.4, billing software for traffic counting working withkrion2003-10-046-0/+58 * [new port] polish/webalizer2edwin2003-10-012-0/+20 * Update to 1.9.2derwin2003-09-256-6/+4 * update polish/ekg-1.1 -> ekg-1.3edwin2003-09-242-2/+2 * Translation update: fix checksum.will2003-09-222-2/+2 * Upgrade to Qt 3.2.1 / KDE 3.1.4. See x11/kde3/Makefile rev 1.64 for details.will2003-09-182-2/+2 * Add kadu, a QT based gadu-gadu client.arved2003-09-106-0/+482 * We no longer need the -pl suffix.marcus2003-08-311-1/+1 * Correct the path for RDEP.marcus2003-08-311-1/+1 * Complete repo copy to polish/openoffice.marcus2003-08-312-2/+2 * Complete repo copy to polish/ooodict_PL.marcus2003-08-311-1/+1 * Tie some forgotten ports into the build.marcus2003-08-311-1/+3 * correct the path of MASTERDIRleeym2003-08-261-1/+1 * Bad MASTERDIR valueedwin2003-08-222-2/+2 * Add a COMMENT filearved2003-08-191-0/+1 * - Update the Categories after Repocopy.arved2003-08-1912-19/+19 * Add an implicit pl- PKGNAMEPREFIX for all Polish ports.marcus2003-08-171-0/+4 * Add empty subdir makefiles for the new dns and polish categories. Thesekris2003-08-161-0/+4 * Fix the REINPLACE_CMDarved2003-08-092-2/+2 * Move configurationfile from /etc to ${PREFIX}/etc.arved2003-08-042-0/+18 * Update KDE to the latest official release, KDE 3.1.3lofi2003-07-296-4/+12 * Add portname to the title of the dialogboxarved2003-07-222-2/+2 * Add ekg, a client for the polish IM System gadu-gaduarved2003-07-215-0/+100 * merge from kde-freebsd Repository:arved2003-06-164-0/+24 * Update to KDE 3.1.2lioux2003-05-204-8/+8 * New port: localized messages and documentation for kofficelioux2003-05-2012-0/+210 * - update to 1.9.1ipetef2003-05-114-6/+6 * - update to 1.0.0petef2003-05-1110-88/+256 * Remove USE_GNOMENG.marcus2003-04-212-2/+0 * Rejoice, for the long awaited upgrade to kde 3.1.1 is here!alane2003-04-06