aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-rabbiter/Makefile25
-rw-r--r--net/rubygem-rabbiter/distinfo2
-rw-r--r--net/rubygem-rabbiter/files/patch-lib-rabbiter.rb14
-rw-r--r--net/rubygem-rabbiter/pkg-descr15
5 files changed, 57 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index cf7abab64096..9c08a6c329ac 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1052,6 +1052,7 @@
SUBDIR += rubygem-openid
SUBDIR += rubygem-packetfu
SUBDIR += rubygem-pcaprub
+ SUBDIR += rubygem-rabbiter
SUBDIR += rubygem-rightaws
SUBDIR += rubygem-rightflexiscale
SUBDIR += rubygem-rightgogrid
diff --git a/net/rubygem-rabbiter/Makefile b/net/rubygem-rabbiter/Makefile
new file mode 100644
index 000000000000..99169642ca8a
--- /dev/null
+++ b/net/rubygem-rabbiter/Makefile
@@ -0,0 +1,25 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rabbiter
+PORTVERSION= 2.0.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Rabbiter is a twitter client for Rabbit
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
+RUN_DEPENDS= rubygem-gio2>=1.1.4:${PORTSDIR}/devel/rubygem-gio2 \
+ rubygem-rabbit>=2.0.0:${PORTSDIR}/misc/rubygem-rabbit \
+ rubygem-twitter_oauth>0:${PORTSDIR}/security/rubygem-twitter_oauth \
+ rubygem-twitter-stream>=0.1.16:${PORTSDIR}/net/rubygem-twitter-stream
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/rabbiter
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-rabbiter/distinfo b/net/rubygem-rabbiter/distinfo
new file mode 100644
index 000000000000..3ce0a1f31710
--- /dev/null
+++ b/net/rubygem-rabbiter/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rabbiter-2.0.0.gem) = 1cbb634056d373ea90d9338a005874a3ccedab6c20f53b5bba8a31352877aa1a
+SIZE (rubygem/rabbiter-2.0.0.gem) = 15872
diff --git a/net/rubygem-rabbiter/files/patch-lib-rabbiter.rb b/net/rubygem-rabbiter/files/patch-lib-rabbiter.rb
new file mode 100644
index 000000000000..1f9c9d26a830
--- /dev/null
+++ b/net/rubygem-rabbiter/files/patch-lib-rabbiter.rb
@@ -0,0 +1,14 @@
+--- lib/rabbiter.rb.orig 2013-07-21 22:07:28.000000000 +0900
++++ lib/rabbiter.rb 2013-07-21 22:08:26.000000000 +0900
+@@ -149,9 +149,9 @@
+ @client = Gio::SocketClient.new
+ @client.tls = @options[:ssl]
+ @client.tls_validation_flags = :validate_all
+- if Rabbit::Utils.windows?
++# if Rabbit::Utils.windows?
+ @client.tls_validation_flags -= :unknown_ca
+- end
++# end
+ @connection = @client.connect_to_host(@options[:host], @options[:port])
+ @socket = @connection.socket
+ @socket.blocking = false
diff --git a/net/rubygem-rabbiter/pkg-descr b/net/rubygem-rabbiter/pkg-descr
new file mode 100644
index 000000000000..4f91f6698ea2
--- /dev/null
+++ b/net/rubygem-rabbiter/pkg-descr
@@ -0,0 +1,15 @@
+Rabbiter is a tool that collects tweets related to the talk and
+sends them to Rabbit as comments.
+
+In public conference such as RubyKaigi, audiences tweet comments
+about the listening talk to Twitter. To show the comments to your
+slide showed by Rabbit, you can use Rabbiter.
+
+If you have room to breathe, you can reply to the comments to reflect
+audiences' opinions. An audience can listen your talk with some
+different points of view because an audience can know other's
+comments. Note that you have a risk that audiences are interested
+in audiences' comments rather than your talk. You should ready your
+talk to make very interesting talk rather than audiences' comments.
+
+WWW: http://rabbit-shocker.org/en/rabbiter/