aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/samba-devel/Makefile2
-rw-r--r--net/samba3/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/samba-devel/Makefile b/net/samba-devel/Makefile
index c0df5d6608a3..341bfa23920e 100644
--- a/net/samba-devel/Makefile
+++ b/net/samba-devel/Makefile
@@ -197,7 +197,7 @@ CONFIGURE_ARGS+= --with-expsam=${WANT_EXPSAM_MODULES}
.if defined(WANT_KRB5)
# Relay on PATH
KRB5_PREFIX!= krb5-config --prefix
-.if defined(KRB5_PREFIX)
+.if defined(KRB5_PREFIX) && !empty (KRB5_PREFIX)
CONFIGURE_ARGS+= --with-krb5=${KRB5_PREFIX}
.elif defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME}
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index c0df5d6608a3..341bfa23920e 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -197,7 +197,7 @@ CONFIGURE_ARGS+= --with-expsam=${WANT_EXPSAM_MODULES}
.if defined(WANT_KRB5)
# Relay on PATH
KRB5_PREFIX!= krb5-config --prefix
-.if defined(KRB5_PREFIX)
+.if defined(KRB5_PREFIX) && !empty (KRB5_PREFIX)
CONFIGURE_ARGS+= --with-krb5=${KRB5_PREFIX}
.elif defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME}