aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/hs-hostname/Makefile16
-rw-r--r--net/hs-hostname/distinfo3
-rw-r--r--net/hs-hostname/pkg-descr4
-rw-r--r--net/hs-hostname/pkg-plist14
5 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2fe8ce2c0304..f257303bd1c3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -223,6 +223,7 @@
SUBDIR += howl
SUBDIR += hping
SUBDIR += hping-devel
+ SUBDIR += hs-hostname
SUBDIR += hs-pcap
SUBDIR += htpdate
SUBDIR += http_ping
diff --git a/net/hs-hostname/Makefile b/net/hs-hostname/Makefile
new file mode 100644
index 000000000000..0f8d919cde10
--- /dev/null
+++ b/net/hs-hostname/Makefile
@@ -0,0 +1,16 @@
+# New ports collection makefile for: hs-hostname
+# Date created: May 21, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hostname
+PORTVERSION= 1.0
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Cross-platform means of determining the hostname
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-hostname/distinfo b/net/hs-hostname/distinfo
new file mode 100644
index 000000000000..0bdc711ed1ae
--- /dev/null
+++ b/net/hs-hostname/distinfo
@@ -0,0 +1,3 @@
+MD5 (hostname-1.0.tar.gz) = 9389c8634239e5d6096ef563e59a703f
+SHA256 (hostname-1.0.tar.gz) = 9b43dab1b6da521f35685b20555da00738c8e136eb972458c786242406a9cf5c
+SIZE (hostname-1.0.tar.gz) = 1982
diff --git a/net/hs-hostname/pkg-descr b/net/hs-hostname/pkg-descr
new file mode 100644
index 000000000000..828c88d112a3
--- /dev/null
+++ b/net/hs-hostname/pkg-descr
@@ -0,0 +1,4 @@
+A very simple package providing a cross-platform means of determining
+the hostname.
+
+WWW: http://hackage.haskell.org/package/hostname
diff --git a/net/hs-hostname/pkg-plist b/net/hs-hostname/pkg-plist
new file mode 100644
index 000000000000..be8e89c330ad
--- /dev/null
+++ b/net/hs-hostname/pkg-plist
@@ -0,0 +1,14 @@
+@comment $FreeBSD$
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Network/HostName.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Network
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old