aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/beacon/Makefile1
-rw-r--r--net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h14
2 files changed, 15 insertions, 0 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
index 53c167fd2240..ed7f0ede707d 100644
--- a/net/beacon/Makefile
+++ b/net/beacon/Makefile
@@ -7,6 +7,7 @@
PORTNAME= beacon
PORTVERSION= 0.9.06
+PORTREVISION= 1
CATEGORIES= net perl5 mbone ipv6
MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/Releases/
diff --git a/net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h b/net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h
new file mode 100644
index 000000000000..e9ca6f5f9cc1
--- /dev/null
+++ b/net/beacon/files/patch-Net-RTP-0.4::inet_ntop.h
@@ -0,0 +1,14 @@
+--- Net-RTP-0.4/inet_ntop.h.orig Tue Mar 2 14:00:58 2004
++++ Net-RTP-0.4/inet_ntop.h Tue Mar 2 14:02:27 2004
+@@ -3,7 +3,11 @@
+ extern "C" {
+ #endif
+
++#ifdef __sparc64__ || __amd64__ || __alpha__
++const char *inet_ntop(int af, const void *src, char *dst, socklen_t size);
++#else
+ const char *inet_ntop(int af, const void *src, char *dst, size_t size);
++#endif
+
+ #if defined(__cplusplus)
+ }