aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/dclib/Makefile1
-rw-r--r--net/dclib/files/patch-dclib-core-cxml.cpp23
2 files changed, 24 insertions, 0 deletions
diff --git a/net/dclib/Makefile b/net/dclib/Makefile
index 53c5fb4aefc3..7fc49e34d397 100644
--- a/net/dclib/Makefile
+++ b/net/dclib/Makefile
@@ -8,6 +8,7 @@
PORTNAME= dclib
PORTVERSION= 0.3.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://download.berlios.de/dcgui/
diff --git a/net/dclib/files/patch-dclib-core-cxml.cpp b/net/dclib/files/patch-dclib-core-cxml.cpp
new file mode 100644
index 000000000000..d185d95f5b20
--- /dev/null
+++ b/net/dclib/files/patch-dclib-core-cxml.cpp
@@ -0,0 +1,23 @@
+--- dclib/core/cxml.cpp.orig Thu Aug 12 10:32:06 2004
++++ dclib/core/cxml.cpp Wed Dec 1 23:14:00 2004
+@@ -149,10 +149,8 @@
+ printf("UTF8Toisolat1 transcoding fail: '%s'\n",s);
+ else if ( res == -1 )
+ printf("UTF8Toisolat1 fail: '%s'\n",s);
+- else if ( res == 0 )
+- r = (char*)b;
+ else
+- printf("CXml::xml_UTF8Toisolat1 error %d\n",res);
++ r = (char*)b;
+
+ free(b);
+
+@@ -180,7 +178,7 @@
+
+ if ( res == -1 )
+ printf("isolat1ToUTF8 fail: '%s'\n",s);
+- else if ( res == 0 )
++ else
+ r = (char*)b;
+
+ free(b);