aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/librdkafka/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net/librdkafka/Makefile b/net/librdkafka/Makefile
index 195f83f53b15..3802fa548179 100644
--- a/net/librdkafka/Makefile
+++ b/net/librdkafka/Makefile
@@ -30,6 +30,12 @@ CONFIGURE_ARGS+= --disable-sasl --enable-ssl
USE_LDCONFIG= yes
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200056 && ${ARCH} == i386
+BROKEN= undefined reference to '__atomic_fetch_add_8'
+.endif
+
post-patch:
${REINPLACE_CMD} -e \
's|_ALIGN(|_RE_ALIGN(|g' ${WRKSRC}/src/rdkafka_buf.h \