aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/openntpd/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net/openntpd/Makefile b/net/openntpd/Makefile
index 6378604954f4..2a6ab1b5ff92 100644
--- a/net/openntpd/Makefile
+++ b/net/openntpd/Makefile
@@ -48,9 +48,11 @@ LDFLAGS+= -fstack-protector
LIBS+= -lssp_nonshared
. endif
+# Don't use COPYTREE_SHARE here as it hard links files, and the original files
+# are owned by root, which creates problems of its own.
pre-configure:
- @cd `${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/libressl`${LOCALBASE} \
- && ${COPYTREE_SHARE} . ${WRKDIR}/libressl "! -name *.so*"
+ @cd `${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/libressl`${PREFIX} \
+ && ${FIND} -E . ! -name *.so\* | ${CPIO} -dump ${WRKDIR}/libressl >/dev/null 2>&1
.endif # SSL_DEFAULT
.include <bsd.port.post.mk>