aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/ntop/Makefile11
-rw-r--r--net/ntop/distinfo6
-rw-r--r--net/ntop/files/patch-Makefile.am28
-rw-r--r--net/ntop/files/patch-autogen.sh19
-rw-r--r--net/ntop/files/patch-configure.in48
-rw-r--r--net/ntop/pkg-plist13
6 files changed, 101 insertions, 24 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index 6d1a21991294..bf4636a0a57b 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ntop
-PORTVERSION= 3.3.8
+PORTVERSION= 3.3.9
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,10 +14,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= wxs@FreeBSD.org
COMMENT= Network monitoring tool with command line and web interfaces
-BUILD_DEPENDS= rrdtool>=1.2:${PORTSDIR}/databases/rrdtool
-LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
- gdbm.3:${PORTSDIR}/databases/gdbm \
- png.5:${PORTSDIR}/graphics/png
+BUILD_DEPENDS= rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
+ geoiplookup:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz \
${LOCALBASE}/lib/X11/fonts/URW/a010013l.afm:${PORTSDIR}/x11-fonts/urwfonts
@@ -35,8 +34,6 @@ PLIST_SUB= DBDIR=${DBDIR} \
CONFIGURE_ARGS= --localstatedir=${DBDIR} \
--with-ossl-root=${OPENSSLBASE} \
--with-gdbm-root=${LOCALBASE} \
- --with-gd-root=${LOCALBASE} \
- --with-libpng-root=${LOCALBASE} \
--with-zlib-root=/usr \
--disable-snmp
# we currently disable IPv6
diff --git a/net/ntop/distinfo b/net/ntop/distinfo
index d053109c60a3..1c0e6c4b5cc2 100644
--- a/net/ntop/distinfo
+++ b/net/ntop/distinfo
@@ -1,3 +1,3 @@
-MD5 (ntop-3.3.8.tar.gz) = 19c6a582c285ffae18bf0c3b599d184e
-SHA256 (ntop-3.3.8.tar.gz) = 8e25f3c527493e1495030b1b8cfb09158c75829a740f55c6339674efcc504238
-SIZE (ntop-3.3.8.tar.gz) = 5626313
+MD5 (ntop-3.3.9.tar.gz) = 0c22038e0f2aa003110437b5a5d5a6a5
+SHA256 (ntop-3.3.9.tar.gz) = 606c027d02cdaab7de87475bef8be168e9f18329c2215ac21a518766aa8a331f
+SIZE (ntop-3.3.9.tar.gz) = 4955257
diff --git a/net/ntop/files/patch-Makefile.am b/net/ntop/files/patch-Makefile.am
index 9369510142e0..93942eff21e9 100644
--- a/net/ntop/files/patch-Makefile.am
+++ b/net/ntop/files/patch-Makefile.am
@@ -1,7 +1,27 @@
---- ./Makefile.am.orig Sat Jun 9 17:15:11 2007
-+++ ./Makefile.am Tue Jul 17 12:37:26 2007
-@@ -360,7 +360,6 @@
- done
+--- Makefile.am.orig 2008-12-03 17:00:22.000000000 -0500
++++ Makefile.am 2009-06-02 14:27:56.863148713 -0400
+@@ -76,9 +76,7 @@
+ NTOPDATA = ntop-cert.pem \
+ $(ETTER_PASSIVE) \
+ oui.txt.gz \
+- specialMAC.txt.gz \
+- GeoIPASNum.dat \
+- GeoLiteCity.dat
++ specialMAC.txt.gz
+
+ NTOPHTML = html html/*.js html/*.html html/*.gif html/*.jpg html/*.ico html/*.png \
+ html/*.css html/*.dtd \
+@@ -270,8 +268,6 @@
+
+ install: install-recursive
+
+- cd @GEO_DIR@; make install
+-
+ @mkdir -p $(DESTDIR)/$(CFG_DBFILE_DIR)
+
+ @echo ""
+@@ -336,7 +332,6 @@
+
install-data-local: ntop.txt ntop.html faq.html
- @$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(libdir)/plugins;
diff --git a/net/ntop/files/patch-autogen.sh b/net/ntop/files/patch-autogen.sh
new file mode 100644
index 000000000000..c7e68b56319e
--- /dev/null
+++ b/net/ntop/files/patch-autogen.sh
@@ -0,0 +1,19 @@
+--- autogen.sh.orig 2009-06-02 10:26:46.731977294 -0400
++++ autogen.sh 2009-06-02 10:27:02.866983000 -0400
+@@ -244,16 +244,6 @@
+ GNU_OR_DIE=0
+ }
+
+-WGET=`find_command 'wget*'`
+-($WGET --version) < /dev/null > /dev/null 2>&1 ||
+-{
+- echo
+- echo "You must have wget installed to compile $progname."
+- echo "Download the appropriate package for your distribution, or get the"
+- echo "source tarball from ftp://ftp.gnu.org/pub/gnu/wget"
+- GNU_OR_DIE=0
+-}
+-
+ if test "$GNU_OR_DIE" -eq 0; then
+ exit 1
+ fi
diff --git a/net/ntop/files/patch-configure.in b/net/ntop/files/patch-configure.in
index 984497fee14a..1d11d9fea18a 100644
--- a/net/ntop/files/patch-configure.in
+++ b/net/ntop/files/patch-configure.in
@@ -1,6 +1,6 @@
---- ./configure.in.orig Sat Jun 9 17:30:00 2007
-+++ ./configure.in Tue Jul 17 12:37:26 2007
-@@ -577,8 +577,8 @@
+--- configure.in.orig 2008-12-03 17:00:22.000000000 -0500
++++ configure.in 2009-06-02 13:28:01.067367126 -0400
+@@ -573,8 +573,8 @@
dnl>
if test ".${PCAP_ROOT}" != .; then
if test -d $PCAP_ROOT &&
@@ -11,3 +11,45 @@
PCAP_ROOT=`cd ${PCAP_ROOT} && pwd`
CORELIBS="${CORELIBS} -L$PCAP_ROOT -lpcap"
INCS="${INCS} -I$PCAP_ROOT"
+@@ -1886,40 +1886,7 @@
+ }'`
+ fi
+
+-dnl> GeoIP (http://www.maxmind.com/)
+-if test -f "GeoIP.tar.gz"; then
+- echo "GeoIP already present on this machine"
+-else
+- wget http://www.maxmind.com/download/geoip/api/c/GeoIP.tar.gz
+- tar xvfz GeoIP.tar.gz
+- GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
+- cd $GEO_DIR; ./configure; make; cd ..
+- # OSX Fix
+- GEO_DYLIB="$GEO_DIR/libGeoIP/.libs/libGeoIP.dylib"
+- if test -f $GEO_DYLIB; then
+- ln -s $GEO_DYLIB .
+- fi
+-fi
+-
+-if test -f "GeoLiteCity.dat"; then
+- echo "GeoLiteCity.dat already present"
+-else
+- wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
+- gunzip GeoLiteCity.dat.gz
+-fi
+-
+-if test -f "GeoIPASNum.dat"; then
+- echo "GeoIPASNum.dat already present"
+-else
+- wget http://www.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
+- gunzip GeoIPASNum.dat.gz
+-fi
+-
+-
+-GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
+-GEO_IP="$GEO_DIR/libGeoIP/"
+-CFLAGS="$CFLAGS -I$GEO_IP"
+-LDFLAGS="$LDFLAGS -L$GEO_IP.libs/ -lGeoIP"
++LDFLAGS="$LDFLAGS -lGeoIP"
+
+ dnl> NTOPCONFIGDEBUG_SETTINGS([precet])
+
diff --git a/net/ntop/pkg-plist b/net/ntop/pkg-plist
index 3fcb4e227d7b..f838159229c9 100644
--- a/net/ntop/pkg-plist
+++ b/net/ntop/pkg-plist
@@ -1,12 +1,9 @@
-@exec mkdir -p %%DBDIR%%/ntop
bin/ntop
%%ASDATA%%etc/ntop/AS-list.txt.gz
etc/ntop/etter.finger.os.gz
etc/ntop/ntop-cert.pem
etc/ntop/oui.txt.gz
-etc/ntop/p2c.opt.table.gz
etc/ntop/specialMAC.txt.gz
-@dirrm etc/ntop
lib/libcpacketPlugin-%%PORTVERSION%%.so
lib/libcpacketPlugin.so
lib/libcpacketPlugin.a
@@ -47,9 +44,8 @@ lib/ntop/plugins/pdaPlugin.so
lib/ntop/plugins/remotePlugin.so
lib/ntop/plugins/rrdPlugin.so
lib/ntop/plugins/sflowPlugin.so
-@dirrm lib/ntop/plugins
-@dirrm lib/ntop
%%DATADIR%%/perl/report/basic.xml
+%%DATADIR%%/html/multihomed.png
%%DATADIR%%/perl/report.pl
%%DATADIR%%/perl/test.pl
%%DATADIR%%/html/ntop_logo.png
@@ -126,7 +122,6 @@ lib/ntop/plugins/sflowPlugin.so
%%DATADIR%%/html/major.gif
%%DATADIR%%/html/marchio_unipi_pant541_144.gif
%%DATADIR%%/html/minor.gif
-%%DATADIR%%/html/multihomed.gif
%%DATADIR%%/html/multivlaned.gif
%%DATADIR%%/html/nboxLogo.gif
%%DATADIR%%/html/ntop.gif
@@ -425,7 +420,8 @@ lib/ntop/plugins/sflowPlugin.so
%%DATADIR%%/html/jscalendar/calendar-setup.js
%%DATADIR%%/html/jscalendar/calendar.js
%%DATADIR%%/html/jscalendar/lang/calendar-en.js
-@dirrm %%DATADIR%%/perl/report/
+@exec mkdir -p %%DBDIR%%/ntop
+@dirrm %%DATADIR%%/perl/report
@dirrm %%DATADIR%%/perl
@dirrm %%DATADIR%%/html/jscalendar/lang
@dirrm %%DATADIR%%/html/jscalendar
@@ -437,3 +433,6 @@ lib/ntop/plugins/sflowPlugin.so
@dirrm %%DATADIR%%/html/statsicons
@dirrm %%DATADIR%%/html
@dirrm %%DATADIR%%
+@dirrm etc/ntop
+@dirrm lib/ntop/plugins
+@dirrm lib/ntop