aboutsummaryrefslogtreecommitdiffstats
path: root/news/inn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/inn/Makefile')
-rw-r--r--news/inn/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/news/inn/Makefile b/news/inn/Makefile
index fdfbb8a7df17..4bb1bc5ab8dc 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -7,7 +7,7 @@
PORTNAME= inn
PORTVERSION= 2.4.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= news ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= inn
@@ -20,7 +20,7 @@ USE_GMAKE= yes
USE_PERL5= yes
USE_OPENSSL= yes
-CONFLICTS= inn-*
+CONFLICTS= inn-stable-* inn-current
.if exists(/var/news) && !defined(PACKAGE_BUILDING)
INN_NEWSSPOOL?=/var/news
@@ -38,14 +38,24 @@ CONFIGURE_ARGS+= --mandir=${PREFIX}/man \
--with-spool-dir=${INN_NEWSSPOOL} \
--with-log-dir=${INN_NEWSLOG} \
--with-perl \
- --with-tmp-path=${INN_NEWSSPOOL}/tmp \
+ --with-tmp-dir=${INN_NEWSSPOOL}/tmp \
--with-openssl=${OPENSSLBASE} \
--enable-ipv6
.if defined(WITH_BERKELEYDB)
-# We don't support other versions for the moment.
CONFIGURE_ARGS+= --with-berkeleydb
-LIB_DEPENDS+= db4:${PORTSDIR}/databases/db4
+. if !defined(WITH_BDB_VER)
+WITH_BDB_VER= 4
+. endif
+. if (${WITH_BDB_VER} == 3) || (${WITH_BDB_VER} == 4)
+LIB_DEPENDS+= db${WITH_BDB_VER}:${PORTSDIR}/databases/db${WITH_BDB_VER}
+. elif ${WITH_BDB_VER} == 2
+BROKEN= "Does not compile with db2"
+. else
+BROKEN= "Unknown BerkeleyDB version"
+. endif
+CONFIGURE_ENV+= DB_VER=db${WITH_BDB_VER}
+CONFIGURE_ARGS+= --with-berkeleydb=${LOCALBASE}
.endif
.if defined(WITH_PYTHON)
@@ -134,7 +144,7 @@ post-install:
s+!!PREFIX!!+${PREFIX}+g && ${CHMOD} +x ${PREFIX}/etc/rc.d/innd.sh
@${CHOWN} root:news ${PREFIX}/news/bin/auth/passwd/ckpasswd
@${CHMOD} 4755 ${PREFIX}/news/bin/auth/passwd/ckpasswd
- @PKG_PREFIX=${PKG_PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF
@(if [ ! -f ${PREFIX}/news/db/history ] ; then \
${ECHO} 'Creating empty history database...' ; \
cd ${PREFIX}/news/db ; \