aboutsummaryrefslogtreecommitdiffstats
path: root/news/nntpcache/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/nntpcache/Makefile')
-rw-r--r--news/nntpcache/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 98156c7f2295..1a6c55c22962 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -25,8 +25,10 @@ LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
LIB_DEPENDS+= lber.1:${PORTSDIR}/net/openldap12
.endif
.if defined(WITH_LDAP2)
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20-client
-LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap20-client
+WITH_LDAP_VER?= 20
+LDAP_VER= ${WITH_LDAP_VER}
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap${LDAP_VER}-client
+LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap${LDAP_VER}-client
.endif
# This may be set interactively at install-time. NNTPCache will