aboutsummaryrefslogtreecommitdiffstats
path: root/news/p5-News-Article-NoCeM/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/p5-News-Article-NoCeM/Makefile')
-rw-r--r--news/p5-News-Article-NoCeM/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/news/p5-News-Article-NoCeM/Makefile b/news/p5-News-Article-NoCeM/Makefile
new file mode 100644
index 000000000000..10d2d5d7581c
--- /dev/null
+++ b/news/p5-News-Article-NoCeM/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-News-Article-NoCeM
+# Date created: 10 December 2004
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= News-Article-NoCeM
+PORTVERSION= 0.03
+CATEGORIES= news perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= News
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A module to generate accurate NoCeM notices
+
+BUILD_DEPENDS= ${SITE_PERL}/News/Article.pm:${PORTSDIR}/news/p5-News-Article \
+ ${SITE_PERL}/PGP/Sign.pm:${PORTSDIR}/security/p5-PGP-Sign
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= News::Article::NoCeM.3
+PLIST_DIRS= ${SITE_PERL_REL}/${PERL_ARCH}/auto/News/Article/NoCeM
+PLIST_FILES= ${SITE_PERL_REL}/News/Article/NoCeM.pm \
+ ${SITE_PERL_REL}/${PERL_ARCH}/auto/News/Article/NoCeM/.packlist
+
+.include <bsd.port.mk>