aboutsummaryrefslogtreecommitdiffstats
path: root/palm/pose/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'palm/pose/Makefile')
-rw-r--r--palm/pose/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/palm/pose/Makefile b/palm/pose/Makefile
index 09fd77b60414..8ee0226dbee6 100644
--- a/palm/pose/Makefile
+++ b/palm/pose/Makefile
@@ -6,17 +6,16 @@
#
PORTNAME= pose
-PORTVERSION= 3.1
+PORTVERSION= 3.5
CATEGORIES= palm emulators
-MASTER_SITES= http://www.palmos.com/dev/tech/tools/emulator/
-# DISTNAME= emulator_src_31
-DISTFILES= emulator_src_31.tar.gz emulator_skins_16.tar.gz
+MASTER_SITES= http://www.palmos.com/dev/tools/emulator/sources/ \
+ http://www.palmos.com/dev/tools/emulator/:skins
+DISTFILES= emulator_src_3.5.tar.gz \
+ emulator-skins-19.tar.gz:skins
MAINTAINER= wlloyd@slap.net
COMMENT= Palm OS(R) Emulator
-BROKEN= "Does not compile"
-
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
USE_MESA= yes
@@ -24,14 +23,16 @@ WRKSRC= ${WRKDIR}/Emulator_Src_${PORTVERSION}/BuildUnix
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --x-includes=${X11BASE}/include \
- --x-libraries=${X11BASE}/lib
+ --x-libraries=${X11BASE}/lib \
+ --with-x --with-fltk=${X11BASE}
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
+ CFLAGS=-DBROKEN_VIRTUAL_DEFAULT_ARGUMENTS=1 \
LIBS="${PTHREAD_LIBS}"
post-install:
${MKDIR} ${PREFIX}/share/pose
${INSTALL_DATA} "${WRKSRC}/../ROMTransfer/Source/ROM_Transfer.prc" ${PREFIX}/share/pose
@${SED} -e 's#/usr/local#${PREFIX}#g' ${PKGMESSAGE}
- ${CP} -Rp ${WRKDIR}/Skins_v1.6 ${PREFIX}/share/pose/skins
+ ${CP} -Rp ${WRKDIR}/Skins_v1.9 ${PREFIX}/share/pose/skins
.include <bsd.port.mk>