aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
Diffstat (limited to 'palm')
-rw-r--r--palm/synce-gnomevfs/Makefile8
-rw-r--r--palm/synce-gvfs/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/palm/synce-gnomevfs/Makefile b/palm/synce-gnomevfs/Makefile
index 00ca2a6237e8..fa02f9148eb0 100644
--- a/palm/synce-gnomevfs/Makefile
+++ b/palm/synce-gnomevfs/Makefile
@@ -24,4 +24,10 @@ CONFIGURE_ARGS+= --with-librapi=${LOCALBASE} \
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH}==amd64
+BROKEN= does not compile on ${ARCH}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/palm/synce-gvfs/Makefile b/palm/synce-gvfs/Makefile
index 00ca2a6237e8..fa02f9148eb0 100644
--- a/palm/synce-gvfs/Makefile
+++ b/palm/synce-gvfs/Makefile
@@ -24,4 +24,10 @@ CONFIGURE_ARGS+= --with-librapi=${LOCALBASE} \
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH}==amd64
+BROKEN= does not compile on ${ARCH}
+.endif
+
+.include <bsd.port.post.mk>