aboutsummaryrefslogtreecommitdiffstats
path: root/polish/kadu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'polish/kadu/Makefile')
-rw-r--r--polish/kadu/Makefile45
1 files changed, 6 insertions, 39 deletions
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 8cf2493cb740..a8c5e7b8f920 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -6,14 +6,11 @@
#
PORTNAME= kadu
-PORTVERSION= 0.6.5.2
-PORTREVISION= 2
+PORTVERSION= 0.6.5.4
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= http://www.kadu.net/download/stable/:kadu \
http://www.kadu.net/download/additions/:additions \
- http://www.kadu.net/download/modules_extra/spellchecker/:aspell \
- http://www.kadu.net/download/modules_mirror/:modules \
http://kadu.net/~arvenil/tabs/download/${PORTVERSION:C/(([0-9]+\.){2}[0-9]+)(.*)/\1/}/:modtab
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:kadu
DIST_SUBDIR= kadu
@@ -23,14 +20,14 @@ MAINTAINER= mwisnicki+freebsd@gmail.com
COMMENT= QT Gadu-Gadu client
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= gadu.3:${PORTSDIR}/polish/libgadu \
+LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant \
+ gadu.3:${PORTSDIR}/polish/libgadu \
qca.2:${PORTSDIR}/devel/qca \
sndfile.1:${PORTSDIR}/audio/libsndfile
RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
# TODO enable devel/libexecinfo
TABS_MOD_DISTFILE= kadu-tabs-1.2.3.tar.bz2
-ASPELL_MOD_DISTFILE= spellchecker-20080821.tar.bz2
GG6_EMOTS_DISTFILE= kompatybilne_z_GG6.tar.gz
GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
@@ -49,39 +46,11 @@ INSTALLS_ICONS= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-OPTIONS= AO "Build AO sound module" off \
- ASPELL "Build spell checking module" off \
- ARTS "Build aRts sound module" off \
- GG_EMOTS "Install GG-compatible emoticons" off \
+OPTIONS= GG_EMOTS "Install GG-compatible emoticons" off \
TABS "Build tabs module" off
.include <bsd.port.pre.mk>
-.if defined(WITH_AO)
-LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
-PLIST_SUB+= AO_SOUND_MOD=""
-KADU_SHARED_MODULES+= ao_sound
-.else
-PLIST_SUB+= AO_SOUND_MOD="@comment "
-.endif
-
-.if defined(WITH_ASPELL)
-LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
-PLIST_SUB+= ASPELL_MOD=""
-DISTFILES+= ${ASPELL_MOD_DISTFILE}:aspell
-KADU_SHARED_MODULES+= spellchecker
-.else
-PLIST_SUB+= ASPELL_MOD="@comment "
-.endif
-
-.if defined(WITH_ARTS)
-LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
-PLIST_SUB+= ARTS_MOD=""
-KADU_SHARED_MODULES+= arts_sound
-.else
-PLIST_SUB+= ARTS_MOD="@comment "
-.endif
-
.if defined(WITH_GG_EMOTS)
PLIST_SUB+= GG_EMOTS=""
DISTFILES+= ${GG6_EMOTS_DISTFILE}:additions \
@@ -98,7 +67,8 @@ KADU_SHARED_MODULES+= tabs
PLIST_SUB+= TABS_MOD="@comment "
.endif
-KADU_DISABLED_MODULES= alsa_sound
+KADU_SHARED_MODULES+= spellchecker qt4_sound
+KADU_DISABLED_MODULES= alsa_sound amarok1_mediaplayer audacious_mediaplayer mediaplayer
post-patch:
@${FIND} ${WRKSRC} -exec ${GREP} -q "#!/bin/bash" {} \; \
@@ -112,9 +82,6 @@ post-patch:
.for module in ${KADU_STATIC_MODULES}
@${REINPLACE_CMD} -e 's|module_${module}=.|module_${module}=y|g' ${WRKSRC}/.config
.endfor
-.if defined(WITH_ASPELL)
- @cd ${WRKSRC}/modules && ${TAR} -zxf ${_DISTDIR}/${ASPELL_MOD_DISTFILE}
-.endif
.if defined(WITH_GG_EMOTS)
@${REINPLACE_CMD} -e 's|emoticons_gg6_compatible=n|emoticons_gg6_compatible=y|g' ${WRKSRC}/.config
@cd ${WRKSRC}/varia/themes/emoticons && \