aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg_cleanup/Makefile20
-rw-r--r--ports-mgmt/pkg_cleanup/files/Makefile4
2 files changed, 7 insertions, 17 deletions
diff --git a/ports-mgmt/pkg_cleanup/Makefile b/ports-mgmt/pkg_cleanup/Makefile
index 09294c7027d7..db6dc7fcc040 100644
--- a/ports-mgmt/pkg_cleanup/Makefile
+++ b/ports-mgmt/pkg_cleanup/Makefile
@@ -14,24 +14,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= sbin/pkg_cleanup \
man/man1/pkg_cleanup.1.gz
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900000 && ${OSVERSION} < 900038
-IGNORE= requires r223289 or higher to compile
-.endif
-.if ${ARCH} == "powerpc" && ${OSVERSION} > 900000
-BROKEN= Does not build on powerpc-9: undefined reference to 'sqrt'
-.endif
-
do-extract:
- ${MKDIR} ${WRKSRC}
- ${CP} -R ${FILESDIR}/* ${WRKSRC}
-
-do-build:
- make -C ${WRKSRC}
+ @${MKDIR} ${WRKSRC}
+ @${CP} -a ${FILESDIR}/ ${WRKSRC}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pkg_cleanup ${STAGEDIR}${PREFIX}/sbin/pkg_cleanup
+ ${INSTALL_PROGRAM} ${WRKSRC}/pkg_cleanup ${STAGEDIR}${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/pkg_cleanup.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ports-mgmt/pkg_cleanup/files/Makefile b/ports-mgmt/pkg_cleanup/files/Makefile
index 8f60dfa3061b..a6a94a0e10fa 100644
--- a/ports-mgmt/pkg_cleanup/files/Makefile
+++ b/ports-mgmt/pkg_cleanup/files/Makefile
@@ -2,5 +2,7 @@
LDLIBS += -lncursesw
LDLIBS += -ldialog
-pkg_cleanup: pkg_cleanup.c
+all: pkg_cleanup
+
+pkg_cleanup: pkg_cleanup.c