aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg_install/Makefile7
-rw-r--r--ports-mgmt/pkg_install/pkg-plist2
2 files changed, 9 insertions, 0 deletions
diff --git a/ports-mgmt/pkg_install/Makefile b/ports-mgmt/pkg_install/Makefile
index 1ade816e3252..8b9b06fa3ecb 100644
--- a/ports-mgmt/pkg_install/Makefile
+++ b/ports-mgmt/pkg_install/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pkg_install
PORTVERSION= 20080708
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://people.FreeBSD.org/~flz/distfiles/pkg_install/
@@ -25,6 +26,12 @@ OPTIONS= WRAPPER "Use ports version instead of base if more recent" on
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_WRAPPER)
+PLIST_SUB+= WRAPPER=""
+.else
+PLIST_SUB+= WRAPPER="@comment "
+.endif
+
pre-configure:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%MANPREFIX%%,${MANPREFIX},g' \
diff --git a/ports-mgmt/pkg_install/pkg-plist b/ports-mgmt/pkg_install/pkg-plist
index 490fefd4e99d..10d3ed4515dc 100644
--- a/ports-mgmt/pkg_install/pkg-plist
+++ b/ports-mgmt/pkg_install/pkg-plist
@@ -4,3 +4,5 @@ sbin/pkg_delete
sbin/pkg_info
sbin/pkg_updating
sbin/pkg_version
+%%WRAPPER%%@cwd /var/db
+%%WRAPPER%%pkg_install.conf