aboutsummaryrefslogtreecommitdiffstats
path: root/print/c2ps/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/c2ps/Makefile')
-rw-r--r--print/c2ps/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/print/c2ps/Makefile b/print/c2ps/Makefile
new file mode 100644
index 000000000000..ef5170f6aecb
--- /dev/null
+++ b/print/c2ps/Makefile
@@ -0,0 +1,22 @@
+# Created by: Matthew Hunt <mph@pobox.com>
+# $FreeBSD$
+
+PORTNAME= c2ps
+PORTVERSION= 4.0
+PORTREVISION= 2
+CATEGORIES= print
+MASTER_SITES= http://www.cs.technion.ac.il/users/c2ps/
+DISTNAME= c2ps-${PORTVERSION}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A PostScript pretty-printer for C source
+
+CFLAGS+= -g -I${LOCALBASE}/include
+MAN1= c2ps.1
+PLIST_FILES= bin/c2ps
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/c2ps ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/c2ps.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>