aboutsummaryrefslogtreecommitdiffstats
path: root/print/enscript-letter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/enscript-letter/Makefile')
-rw-r--r--print/enscript-letter/Makefile26
1 files changed, 6 insertions, 20 deletions
diff --git a/print/enscript-letter/Makefile b/print/enscript-letter/Makefile
index 301b3650de58..43864954a087 100644
--- a/print/enscript-letter/Makefile
+++ b/print/enscript-letter/Makefile
@@ -19,39 +19,25 @@ COMMENT= ASCII to PostScript filter
CC=
GNU_CONFIGURE= yes
-USE_GMAKE= yes
CONFIGURE_ARGS= --disable-nls --with-media=${PS}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-MAKE_FLAGS= WIDTH=${WIDTH} HEIGHT=${HEIGHT} A4_PAPERSIZE=${A4_PAPERSIZE} -f
INFO= enscript
MAN1= diffpp.1 enscript.1 sliceprint.1 states.1
-STRIP=
-
-# If you want to build a static binary, uncomment the following line
-#LDFLAGS+=-static
PAPERSIZE?= letter
-PS!= ${ECHO} ${PAPERSIZE} | tr l L | tr a A
.if ${PAPERSIZE} == a4
-WIDTH=8.27
-HEIGHT=11.64
-A4_PAPERSIZE=1
+PS=A4
.elif ${PAPERSIZE} == letter
-WIDTH=8.5
-HEIGHT=11.0
-A4_PAPERSIZE=0
-.elif ${PAPERSIZE} != letterdj
+PS=Letter
+.elif ${PAPERSIZE} == letterdj
+PS=Letterdj
+.else
.BEGIN:
@${ECHO} "Error: invalid value for PAPERSIZE: \"${PAPERSIZE}\""
- @${ECHO} "Possible values are: a4 or letter or letterdj"
+ @${ECHO} "Possible values are: a4, letter, or letterdj"
@${FALSE}
.endif
-post-install:
-.for file in enscript mkafmmap states
- ${STRIP_CMD} ${PREFIX}/bin/${file}
-.endfor
-
.include <bsd.port.mk>