aboutsummaryrefslogtreecommitdiffstats
path: root/print/envelope/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/envelope/Makefile')
-rw-r--r--print/envelope/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/print/envelope/Makefile b/print/envelope/Makefile
new file mode 100644
index 000000000000..1b6c5e727116
--- /dev/null
+++ b/print/envelope/Makefile
@@ -0,0 +1,46 @@
+# ex:ts=8
+#
+# New ports collection makefile for: envelope
+# Date created: 2002/03/24
+# Whom: Alan Eldridge ports@geeksrus.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= envelope
+PORTVERSION= 1.0.0
+CATEGORIES= print
+MASTER_SITES= http://freefall.homeip.net/code/envelope/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@geeksrus.net
+
+NO_BUILD= yes
+USE_PERL5= yes
+NO_WRKSUBDIR= yes
+
+PLIST_SUB+= DOCSDIR=${DOCSDIR:S@^${PREFIX}/@@}
+PLIST_SUB+= EXAMPLESDIR=${EXAMPLESDIR:S@^${PREFIX}/@@}
+
+post-patch:
+ @${PERL} -pi -e 's@/usr/bin/perl@${PERL}@' ${WRKDIR}/envelope
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/envelope ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR} ${EXAMPLESDIR}/config
+ @cd ${WRKDIR}; ${INSTALL_DATA} samplerc INSTALL ReadMe ${DOCSDIR}
+ @cd ${WRKDIR}/examples; \
+ ${INSTALL_DATA} normal returnaddress shipping_label \
+ simple with_config with_font_info with_options \
+ ${EXAMPLESDIR}
+ @cd ${WRKDIR}/examples; ${INSTALL_DATA} config/* ${EXAMPLESDIR}/config
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
+
+#EOF