aboutsummaryrefslogtreecommitdiffstats
path: root/print/ifhp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/ifhp/Makefile')
-rw-r--r--print/ifhp/Makefile60
1 files changed, 49 insertions, 11 deletions
diff --git a/print/ifhp/Makefile b/print/ifhp/Makefile
index 1bbd11b8d66b..5ba9bc182527 100644
--- a/print/ifhp/Makefile
+++ b/print/ifhp/Makefile
@@ -1,27 +1,65 @@
-# New ports collection makefile for: ifhp
-# Date created: 27 August 1999
+# Ports collection makefile for: ifhp
+# Date created: 10 Oct 2001
# Whom: papowell@astart.com
#
# $FreeBSD$
#
-PORTNAME= ifhp
-PORTVERSION= 3.3.10
-CATEGORIES= print
-MASTER_SITES= ftp://ftp.astart.com/pub/LPRng/FILTERS/
+PORTNAME=ifhp
+PORTVERSION=3.5.6
+CATEGORIES= print
+MASTER_SITES= ftp://ftp.lprng.com/pub/%SUBDIR%/ \
+ ftp://ftp.cise.ufl.edu/pub/mirrors/%SUBDIR%/ \
+ ftp://ftp.cs.umn.edu/pub/%SUBDIR%/ \
+ ftp://ftp.informatik.uni-hamburg.de/pub/os/unix/utils/%SUBDIR%/ \
+ ftp://ftp.uni-paderborn.de/pub/unix/printer/%SUBDIR%/
+MASTER_SITE_SUBDIR= LPRng/ifhp
EXTRACT_SUFX= .tgz
-MAINTAINER= papowell@astart.com
+MAINTAINER=papowell@astart.com
+
+# RUN_DEPENDS=
+
+.if defined(PREFIX)
+ CONFIGURE_ARGS+= --prefix="${PREFIX}"
+.endif
+.if defined(SYSCONFDIR)
+ CONFIGURE_ARGS+= --sysconfdir="${SYSCONFDIR}"
+.endif
-MAKEFILE= Makefile.bsd
HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ARGS+= \
+ --with-ldopts="-L${LOCALBASE}/lib" \
+ --with-ccopts="-I${LOCALBASE}/include"
+
+MAN8=ifhp.8 textps.8
-MAN8= ifhp.8 textps.8
+pre-everything::
+ @${ECHO_MSG} "If you want to replace the default printing system with LPRng, use:"
+ @${ECHO_MSG} " make PREFIX=/usr SYSCONFDIR=/etc clean all install"
+ @if [ "${PREFIX}" = "/usr" -a ! -d /usr/man ] ; then \
+ ${ECHO_MSG} "The man pages will be installed in /usr/man." ; \
+ ${ECHO_MSG} "You should make a symbolic link /usr/share/man from /usr/man"; \
+ ${ECHO_MSG} " ln -s /usr/share/man /usr/man"; \
+ ${ECHO_MSG} "If you do not, you will retain the old FreeBSD man pages."; \
+ ${ECHO_MSG} "See the hier(7) man page for details of the FreeBSD file system"; \
+ ${ECHO_MSG} "layout. Configure is not equipped to determine the location of"; \
+ ${ECHO_MSG} 'man pages and defaults to $${PREFIX}/man, which is incorrect for FreeBSD.'; \
+ exit 1; \
+ fi
+ @${ECHO_MSG} "Configuring with '${CONFIGURE_ARGS}'"
post-install:
- ${INSTALL} -d -g bin -o bin -m 0555 ${PREFIX}/share/doc/ifhp
.if !defined(NOPORTSDOCS)
- ${CP} -r ${WRKSRC}/HOWTO/* ${PREFIX}/share/doc/ifhp;
+ @${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 0555 ${DOCSDIR}
+.for ext in html pdf ppt ps txt gif jpg png
+ @for i in `ls ${WRKSRC}/HOWTO |${GREP} "\.${ext}$$"`; \
+ do ${INSTALL_DATA} ${WRKSRC}/HOWTO/$$i ${DOCSDIR}; done
+.endfor
.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>