aboutsummaryrefslogtreecommitdiffstats
path: root/print/libspectre/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/libspectre/Makefile')
-rw-r--r--print/libspectre/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/print/libspectre/Makefile b/print/libspectre/Makefile
new file mode 100644
index 000000000000..088dbfddf853
--- /dev/null
+++ b/print/libspectre/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: libspectre
+# Date created: 2008-03-12
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/print/libspectre/Makefile,v 1.2 2008/03/13 16:30:50 ahze Exp $
+
+PORTNAME= libspectre
+PORTVERSION= 0.2.0
+CATEGORIES= print
+MASTER_SITES= http://libspectre.freedesktop.org/releases/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A small library for rendering Postscript documents
+
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
+
+USE_AUTOTOOLS= libtool:15
+USE_LDCONFIG= yes
+USE_GNOME= gnomehack gnomeprefix ltverhack
+USE_GHOSTSCRIPT=yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>