aboutsummaryrefslogtreecommitdiffstats
path: root/print/panda/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/panda/Makefile')
-rw-r--r--print/panda/Makefile29
1 files changed, 11 insertions, 18 deletions
diff --git a/print/panda/Makefile b/print/panda/Makefile
index 235d32f6b5bc..4dc5b12c3a89 100644
--- a/print/panda/Makefile
+++ b/print/panda/Makefile
@@ -15,22 +15,20 @@ COMMENT= A PDF generation library
LICENSE= GPLv2 LGPL21
LICENSE_COMB= dual
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
-USES= pathfix pkgconfig gmake tar:bzip2
+USES= pathfix pkgconfig gmake tar:bzip2
USE_BDB= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --enable-berkeley-db
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${BDB_LIB_DIR} -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
post-extract:
.for file in config.sub config.guess
@${RM} ${WRKSRC}/config/${file} && ${TOUCH} ${WRKSRC}/config/${file}
@@ -41,19 +39,14 @@ post-patch:
${WRKSRC}/examples/Makefile.in
post-install:
- ${INSTALL_MAN} ${WRKSRC}/man/panda_*.3 ${MANPREFIX}/man/man3
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/man/panda_*.3 ${STAGEDIR}${MANPREFIX}/man/man3
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in AUTHORS CONTRIBUTORS ChangeLog DEV-HINTS README TODO UNDERWAY
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in IMAGES examples/*.c examples/c++/*.cpp examples/images/*.*
- ${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${EXAMPLESDIR}
.endfor
-.endif
-.include "Makefile.man"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>