aboutsummaryrefslogtreecommitdiffstats
path: root/print/py-psautohint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/py-psautohint/Makefile')
-rw-r--r--print/py-psautohint/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/print/py-psautohint/Makefile b/print/py-psautohint/Makefile
index 3cd0d1b65f98..6eea06b710e2 100644
--- a/print/py-psautohint/Makefile
+++ b/print/py-psautohint/Makefile
@@ -2,7 +2,7 @@
PORTNAME= psautohint
PORTVERSION= 1.9.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +14,6 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fonttools>=3.32.0:print/py-fonttools@${PY_FLAVOR}
USES= python zip
USE_PYTHON= autoplist concurrent distutils
@@ -22,4 +21,12 @@ USE_PYTHON= autoplist concurrent distutils
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/psautohint/_psautohint.so
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3600
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}fonttools3>=3.32.0:print/py-fonttools3@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}fonttools>=3.32.0:print/py-fonttools@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>