aboutsummaryrefslogtreecommitdiffstats
path: root/print/py-pyscript/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/py-pyscript/Makefile')
-rw-r--r--print/py-pyscript/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/print/py-pyscript/Makefile b/print/py-pyscript/Makefile
new file mode 100644
index 000000000000..b406c74aecc3
--- /dev/null
+++ b/print/py-pyscript/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: py-script
+# Date created: 2006-04-28
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyscript
+PORTVERSION= 0.6
+CATEGORIES= print graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@email.it
+COMMENT= Python module for producing high quality PostScript graphics
+
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
+ dvips:${PORTSDIR}/print/dvipsk-tetex
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+DATADIR= ${PYTHON_SITELIBDIR}/${PORTNAME}
+
+PYSCRIPT_EXAMPLES= doc/examples/*.py
+PYSCRIPT_MANUAL= doc/manual/pyscript.pdf
+
+.if defined(WITHOUT_EXAMPLES)
+PORTEXAMPLES= "@comment "
+.else
+PORTEXAMPLES= ""
+.endif
+PLIST_SUB+= PORTEXAMPLES=${PORTEXAMPLES}
+
+post-install:
+
+.if !defined(WITHOUT_EXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PYSCRIPT_EXAMPLES} ${EXAMPLESDIR}
+.endif
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PYSCRIPT_MANUAL} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>