aboutsummaryrefslogtreecommitdiffstats
path: root/print/qpdfview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/qpdfview/Makefile')
-rw-r--r--print/qpdfview/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index 3565394720dc..5a3f410949a4 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= qpdfview
-PORTVERSION= 0.4.14
-PORTREVISION= 1
+PORTVERSION= 0.4.16
CATEGORIES= print
-MASTER_SITES= https://launchpad.net/qpdfview/trunk/0.4.14/+download/
+MASTER_SITES= https://launchpadlibrarian.net/226592308/ \
+ https://launchpad.net/${PORTVERSION}/trunk/${PORTVERSION}/+download/
MAINTAINER= vg@FreeBSD.org
COMMENT= Tabbed DjVu/PDF/PS document viewer
@@ -13,19 +13,18 @@ COMMENT= Tabbed DjVu/PDF/PS document viewer
LICENSE= GPLv2
USES= desktop-file-utils pkgconfig qmake
-USE_QT4= corelib dbus gui imageformats_run linguisttools_build \
- moc_build rcc_build sql sql-sqlite3_run svg xml
USE_LDCONFIG= yes
-QMAKE_ARGS+= QMAKE_CFLAGS_RELEASE="" QMAKE_CXXFLAGS_RELEASE=""
QMAKE_SOURCE_PATH= ${PORTNAME}.pro
DATADIR= ${PREFIX}/share/${PORTNAME}
+OPTIONS_SINGLE= TOOLKITS
+OPTIONS_SINGLE_TOOLKITS= QT4 QT5
OPTIONS_DEFINE= CUPS
OPTIONS_MULTI= BACKEND
-OPTIONS_MULTI_BACKEND= DJVU PDF PS
-BACKEND_DESC= Documents support
-OPTIONS_DEFAULT= CUPS PDF
+OPTIONS_MULTI_BACKEND= DJVU PS
+BACKEND_DESC= Additional documents support
+OPTIONS_DEFAULT= QT4 CUPS PS
OPTIONS_SUB= yes
CUPS_QMAKE_OFF= "CONFIG+=without_cups"
@@ -34,8 +33,11 @@ CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
DJVU_LIB_DEPENDS= libdjvulibre.so:${PORTSDIR}/graphics/djvulibre
DJVU_QMAKE_OFF= "CONFIG+=without_djvu"
-PDF_LIB_DEPENDS= libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4
-PDF_QMAKE_OFF= "CONFIG+=without_pdf"
+QT4_USE= qt4=dbus,gui,linguisttools,sql,sql-sqlite3,svg,xml
+QT4_LIB_DEPENDS= libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4
+
+QT5_USE= qt5=concurrent,linguisttools,printsupport,sql,sql-sqlite3
+QT5_LIB_DEPENDS= libpoppler-qt5.so:${PORTSDIR}/graphics/poppler-qt5
PS_LIB_DEPENDS= libspectre.so:${PORTSDIR}/print/libspectre
PS_QMAKE_OFF= "CONFIG+=without_ps"