aboutsummaryrefslogtreecommitdiffstats
path: root/print/rubygem-pdfwriter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/rubygem-pdfwriter/Makefile')
-rw-r--r--print/rubygem-pdfwriter/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/print/rubygem-pdfwriter/Makefile b/print/rubygem-pdfwriter/Makefile
new file mode 100644
index 000000000000..29c3e336a354
--- /dev/null
+++ b/print/rubygem-pdfwriter/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: gem-pdfwriter
+# Date created: 09 nov 2005
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+
+PORTNAME= pdfwriter
+PORTVERSION= 1.1.3
+CATEGORIES= print ruby
+MASTER_SITES= http://rubyforge.org/frs/download.php/5993/
+DISTNAME= pdf-writer-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Working with PDF documents in pure Ruby
+
+BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/color-tools-1.3.0.gemspec:${PORTSDIR}/${PKGCATEGORY}/rubygem-colortools
+BUILD_DEPENDS+= ${LOCALBASE}/${SPEC_DIR}/transaction-simple-1.3.0.gemspec:${PORTSDIR}/devel/rubygem-transactionsimple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>