aboutsummaryrefslogtreecommitdiffstats
path: root/print/xtexsh/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/xtexsh/Makefile')
-rw-r--r--print/xtexsh/Makefile38
1 files changed, 20 insertions, 18 deletions
diff --git a/print/xtexsh/Makefile b/print/xtexsh/Makefile
index 16a4b68527e8..f87bfa2b9c02 100644
--- a/print/xtexsh/Makefile
+++ b/print/xtexsh/Makefile
@@ -14,39 +14,41 @@ COMMENT= Tcl/Tk-based simple TeX interface
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
+OPTIONS_DEFINE= DOCS
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
NO_BUILD= yes
USE_TEX= latex
-USE_TK_WRAPPER= yes
+USES+= tk desktop-file-utils
INSTALLS_ICONS= yes
-MAN1= xtexsh.1
-MANCOMPRESSED= yes
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
- 's|/usr/bin|${LOCALBASE}/bin|g ; \
+ 's|/usr/bin/wish|${WISH}|g ; \
s|"/etc|"${PREFIX}/etc| ; \
s|exec bash|exec sh|' ${WRKSRC}/xtexsh
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/xtexsh ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/xtexsh.1.gz ${MANPREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/xtexshrc ${PREFIX}/etc
- ${INSTALL_DATA} ${WRKSRC}/xtexsh.desktop ${PREFIX}/share/applications
- @${MKDIR} ${PREFIX}/share/icons/locolor/16x16/apps
+ ${INSTALL_SCRIPT} ${WRKSRC}/xtexsh ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xtexsh.1.gz ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/xtexshrc ${STAGEDIR}${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/xtexsh.desktop ${STAGEDIR}${PREFIX}/share/applications
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/locolor/16x16/apps
${INSTALL_DATA} ${WRKSRC}/xtexsh-mini.png \
- ${PREFIX}/share/icons/locolor/16x16/apps/xtexsh.png
- @${MKDIR} ${PREFIX}/share/icons/locolor/32x32/apps
+ ${STAGEDIR}${PREFIX}/share/icons/locolor/16x16/apps/xtexsh.png
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/locolor/32x32/apps
${INSTALL_DATA} ${WRKSRC}/xtexsh.png \
- ${PREFIX}/share/icons/locolor/32x32/apps/xtexsh.png
- ${INSTALL_DATA} ${WRKSRC}/xtexsh.png ${PREFIX}/share/pixmaps
+ ${STAGEDIR}${PREFIX}/share/icons/locolor/32x32/apps/xtexsh.png
+ ${INSTALL_DATA} ${WRKSRC}/xtexsh.png ${STAGEDIR}${PREFIX}/share/pixmaps
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/index.html ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>