aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/ifhp/Makefile60
-rw-r--r--print/ifhp/distinfo2
-rw-r--r--print/ifhp/pkg-comment2
-rw-r--r--print/ifhp/pkg-descr15
-rw-r--r--print/ifhp/pkg-plist39
5 files changed, 60 insertions, 58 deletions
diff --git a/print/ifhp/Makefile b/print/ifhp/Makefile
index 1bbd11b8d66b..5ba9bc182527 100644
--- a/print/ifhp/Makefile
+++ b/print/ifhp/Makefile
@@ -1,27 +1,65 @@
-# New ports collection makefile for: ifhp
-# Date created: 27 August 1999
+# Ports collection makefile for: ifhp
+# Date created: 10 Oct 2001
# Whom: papowell@astart.com
#
# $FreeBSD$
#
-PORTNAME= ifhp
-PORTVERSION= 3.3.10
-CATEGORIES= print
-MASTER_SITES= ftp://ftp.astart.com/pub/LPRng/FILTERS/
+PORTNAME=ifhp
+PORTVERSION=3.5.6
+CATEGORIES= print
+MASTER_SITES= ftp://ftp.lprng.com/pub/%SUBDIR%/ \
+ ftp://ftp.cise.ufl.edu/pub/mirrors/%SUBDIR%/ \
+ ftp://ftp.cs.umn.edu/pub/%SUBDIR%/ \
+ ftp://ftp.informatik.uni-hamburg.de/pub/os/unix/utils/%SUBDIR%/ \
+ ftp://ftp.uni-paderborn.de/pub/unix/printer/%SUBDIR%/
+MASTER_SITE_SUBDIR= LPRng/ifhp
EXTRACT_SUFX= .tgz
-MAINTAINER= papowell@astart.com
+MAINTAINER=papowell@astart.com
+
+# RUN_DEPENDS=
+
+.if defined(PREFIX)
+ CONFIGURE_ARGS+= --prefix="${PREFIX}"
+.endif
+.if defined(SYSCONFDIR)
+ CONFIGURE_ARGS+= --sysconfdir="${SYSCONFDIR}"
+.endif
-MAKEFILE= Makefile.bsd
HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ARGS+= \
+ --with-ldopts="-L${LOCALBASE}/lib" \
+ --with-ccopts="-I${LOCALBASE}/include"
+
+MAN8=ifhp.8 textps.8
-MAN8= ifhp.8 textps.8
+pre-everything::
+ @${ECHO_MSG} "If you want to replace the default printing system with LPRng, use:"
+ @${ECHO_MSG} " make PREFIX=/usr SYSCONFDIR=/etc clean all install"
+ @if [ "${PREFIX}" = "/usr" -a ! -d /usr/man ] ; then \
+ ${ECHO_MSG} "The man pages will be installed in /usr/man." ; \
+ ${ECHO_MSG} "You should make a symbolic link /usr/share/man from /usr/man"; \
+ ${ECHO_MSG} " ln -s /usr/share/man /usr/man"; \
+ ${ECHO_MSG} "If you do not, you will retain the old FreeBSD man pages."; \
+ ${ECHO_MSG} "See the hier(7) man page for details of the FreeBSD file system"; \
+ ${ECHO_MSG} "layout. Configure is not equipped to determine the location of"; \
+ ${ECHO_MSG} 'man pages and defaults to $${PREFIX}/man, which is incorrect for FreeBSD.'; \
+ exit 1; \
+ fi
+ @${ECHO_MSG} "Configuring with '${CONFIGURE_ARGS}'"
post-install:
- ${INSTALL} -d -g bin -o bin -m 0555 ${PREFIX}/share/doc/ifhp
.if !defined(NOPORTSDOCS)
- ${CP} -r ${WRKSRC}/HOWTO/* ${PREFIX}/share/doc/ifhp;
+ @${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 0555 ${DOCSDIR}
+.for ext in html pdf ppt ps txt gif jpg png
+ @for i in `ls ${WRKSRC}/HOWTO |${GREP} "\.${ext}$$"`; \
+ do ${INSTALL_DATA} ${WRKSRC}/HOWTO/$$i ${DOCSDIR}; done
+.endfor
.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/print/ifhp/distinfo b/print/ifhp/distinfo
index 5ea5000f479c..97c4ec708643 100644
--- a/print/ifhp/distinfo
+++ b/print/ifhp/distinfo
@@ -1 +1 @@
-MD5 (ifhp-3.3.10.tgz) = e3094c65d4acb3b09d79ee08f489ffff
+MD5 (ifhp-3.5.6.tgz) = ca54cb1008c9d0cbb2aa767a1a4810fb
diff --git a/print/ifhp/pkg-comment b/print/ifhp/pkg-comment
index 6bfe434f05f9..2c8bc61d9887 100644
--- a/print/ifhp/pkg-comment
+++ b/print/ifhp/pkg-comment
@@ -1 +1 @@
-LPRng print filter for text, PostScript, PCL, HP, Xerox, etc printers
+IFHP - A highly configurable print filter for LPRng
diff --git a/print/ifhp/pkg-descr b/print/ifhp/pkg-descr
index 204d2c92a35f..6aee42cf03a7 100644
--- a/print/ifhp/pkg-descr
+++ b/print/ifhp/pkg-descr
@@ -1,7 +1,8 @@
-The IFHP print filter is a highly configurable and almost universal
-print filter for the LPRng print spooler. It can handle text, PostScript,
-PCL, and PJL compatible printers, as well as doing synchronization, resetting,
-getting page counts, end of job detection and other administrative functions.
-It will handle HP, Tektronics, Xerox, Qume, and just about any printer that
-can accept a connection. Configuration is done using the /etc/ifhp.conf file
-which can be tailored for your particular printer.
+ifhp is a highly versatile print filter for BSD based print spoolers.
+It can be configured to handle text, PostScript, PJL, PCL, and
+raster printers, supports conversion from one format to another,
+and can be used as a stand-alone print utility. It is the primary
+supported print filter for the LPRng print spooler.
+
+WWW: http://www.lprng.com
+FTP: ftp://ftp.lprng.com
diff --git a/print/ifhp/pkg-plist b/print/ifhp/pkg-plist
index a0667f70f96d..cca87333bcc2 100644
--- a/print/ifhp/pkg-plist
+++ b/print/ifhp/pkg-plist
@@ -1,41 +1,4 @@
-etc/ifhp.conf
etc/ifhp.conf.sample
libexec/filters/ifhp
libexec/filters/textps
-libexec/filters/accounting.sh
-libexec/filters/psbanner.ps
-libexec/filters/ofhp
-libexec/filters/banner
-share/doc/ifhp/IFHP-HOWTO-1.html
-share/doc/ifhp/options
-share/doc/ifhp/fixoptions
-share/doc/ifhp/Makefile.in
-share/doc/ifhp/Makefile.bsd.in
-share/doc/ifhp/Makefile.bsd
-share/doc/ifhp/Makefile
-share/doc/ifhp/IFHP-HOWTO.txt
-share/doc/ifhp/IFHP-HOWTO.tex
-share/doc/ifhp/IFHP-HOWTO.sgml
-share/doc/ifhp/IFHP-HOWTO.ps
-share/doc/ifhp/IFHP-HOWTO.info-4
-share/doc/ifhp/IFHP-HOWTO.info-3
-share/doc/ifhp/IFHP-HOWTO.info-2
-share/doc/ifhp/IFHP-HOWTO.info-1
-share/doc/ifhp/IFHP-HOWTO.info
-share/doc/ifhp/IFHP-HOWTO.html
-share/doc/ifhp/IFHP-HOWTO.dvi
-share/doc/ifhp/IFHP-HOWTO-9.html
-share/doc/ifhp/IFHP-HOWTO-8.html
-share/doc/ifhp/IFHP-HOWTO-7.html
-share/doc/ifhp/IFHP-HOWTO-6.html
-share/doc/ifhp/IFHP-HOWTO-5.html
-share/doc/ifhp/IFHP-HOWTO-4.html
-share/doc/ifhp/IFHP-HOWTO-3.html
-share/doc/ifhp/IFHP-HOWTO-2.html
-share/doc/ifhp/IFHP-HOWTO-12.html
-share/doc/ifhp/IFHP-HOWTO-11.html
-share/doc/ifhp/IFHP-HOWTO-10.html
-share/doc/ifhp/dict
-share/doc/ifhp/updateversion
-@dirrm libexec/filters
-@dirrm share/doc/ifhp
+libexec/filters/wrapper