aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/acroread/Makefile62
-rw-r--r--print/acroread/distinfo4
-rw-r--r--print/acroread/files/patch-aa32
-rw-r--r--print/acroread/pkg-deinstall3
-rw-r--r--print/acroread/pkg-descr2
-rw-r--r--print/acroread/pkg-install3
-rw-r--r--print/acroread/pkg-plist92
7 files changed, 154 insertions, 44 deletions
diff --git a/print/acroread/Makefile b/print/acroread/Makefile
index 0205d0e3cecd..0540f2e22820 100644
--- a/print/acroread/Makefile
+++ b/print/acroread/Makefile
@@ -6,55 +6,49 @@
#
PORTNAME= acroread
-PORTVERSION= 7.0.0
+PORTVERSION= 5.10
+PORTREVISION= 1
CATEGORIES= print linux
-MASTER_SITES= http://download.adobe.com/pub/adobe/reader/unix/7x/7.0/enu/ \
- ftp://ftp.adobe.com/pub/adobe/reader/unix/7x/7.0/enu/
-DISTNAME= AdobeReader_enu-7.0.0-1.i386.rpm
-EXTRACT_SUFX=
+MASTER_SITES= http://download.adobe.com/pub/adobe/acrobatreader/unix/5.x/ \
+ ftp://ftp.adobe.com/pub/adobe/acrobatreader/unix/5.x/
+.include <bsd.port.pre.mk>
+DISTNAME= linux-5010
DIST_SUBDIR= acroread
-EXTRACT_ONLY=
MAINTAINER= trevor@FreeBSD.org
COMMENT= View, distribute and print PDF documents
-BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2 \
- ${LINUXBASE}/usr/lib/libpango-1.0.so.0:${PORTSDIR}/x11-toolkits/linux-pango \
- ${LINUXBASE}/usr/X11R6/lib/libXext.so.6:${PORTSDIR}/x11/linux-XFree86-libs
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs
ONLY_FOR_ARCHS= amd64 i386
USE_REINPLACE= yes
NO_BUILD= yes
REINPLACE_ARGS= -i '' -E
NO_FILTER_SHLIBS= yes
-PLIST= ${WRKDIR}/plist
-PREFIX= ${LINUXBASE}
-
-pre-install:
- @kldstat -v | grep -E 'linux(aout|elf)' >/dev/null ||\
- { ${ECHO_MSG} "Linux ABI compatibility must be enabled to install ${PORTNAME}-${PORTVERSION}"; \
- exit 1; }
- @${RM} -rf ${WRKSRC}/tmp
- @${MKDIR} ${WRKSRC}/tmp
- cd ${WRKSRC}/tmp; \
- rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} | ${CPIO} -id; \
- ${FIND} * -type f -o -type l > ${PLIST} \
- && ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' | \
- ${GREP} -vE "(usr/bin$$|local$$|share$$|usr$$)" >> ${PLIST}
+
+PLIST_SUB= "ARCHDIR=intellinux"
+WRKSRC= ${WRKDIR}/installers
do-install:
- @rpm -U --ignorearch --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm \
- --nodeps --replacepkgs ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} || ${TRUE}
- # disable the PPKLite plugin as it requires an LDAP share lib
- ${CHMOD} 0 ${PREFIX}/usr/local/Adobe/Acrobat7.0/Reader/intellinux/plug_ins/PPKLite.api
+ @${MKDIR} ${PREFIX}/Acrobat5
+ @ReadInstallDir=${PREFIX}/Acrobat5 ${WRKSRC}/INSTALL
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ strings -1 ${WRKSRC}/README > ${DOCSDIR}/README
+.endif
post-install:
- @${REINPLACE_CMD} 's:Linux:FreeBSD|Linux:g' \
- ${PREFIX}/usr/local/Adobe/Acrobat7.0/bin/acroread
- cd ${LOCALBASE}/bin ; ${LN} -sf ${PREFIX}/usr/local/Adobe/Acrobat7.0/bin/acroread acroread7
- cd ${LOCALBASE}/bin ; ${LN} -sf ${PREFIX}/usr/local/Adobe/Acrobat7.0/bin/acroread acroread
+ ${REINPLACE_CMD} 's:Linux):FreeBSD|Linux):g' ${PREFIX}/Acrobat5/bin/acroread
+ @${BRANDELF} -t Linux ${PREFIX}/Acrobat5/Reader/intellinux/bin/acroread
+ ${REINPLACE_CMD} 's:OSF1):FreeBSD|OSF1):g' ${PREFIX}/Acrobat5/bin/acroread
+ @cd ${PREFIX}/Acrobat5/bin && \
+ ${INSTALL_SCRIPT} ${PREFIX}/Acrobat5/bin/acroread \
+ ${PREFIX}/bin/acroread5
+ @${CHOWN} -R -h root:wheel ${PREFIX}/Acrobat5
+ @${CHMOD} +x ${PREFIX}/bin/acroread5
+ [ -e ${PREFIX}/bin/acroread ] \
+ || (cd ${PREFIX}/bin ; ${LN} -sf acroread5 acroread)
@${ECHO_MSG} "Be sure to read the license agreement in"
- @${ECHO_MSG} "${PREFIX}/usr/local/Adobe/Acrobat7.0/Reader/Legal/ENU/license_ENU_uc.txt"
+ @${ECHO_MSG} "${PREFIX}/Acrobat5/Reader/license.txt"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/print/acroread/distinfo b/print/acroread/distinfo
index 01803e00d9f8..dc9eaea7e1e9 100644
--- a/print/acroread/distinfo
+++ b/print/acroread/distinfo
@@ -1,2 +1,2 @@
-MD5 (acroread/AdobeReader_enu-7.0.0-1.i386.rpm) = eba9f1d660f1c6d1ee7783afd63d0e9c
-SIZE (acroread/AdobeReader_enu-7.0.0-1.i386.rpm) = 39866435
+MD5 (acroread/linux-5010.tar.gz) = 9721b85d54aab1d9ece37758cc6d64f2
+SIZE (acroread/linux-5010.tar.gz) = 9286383
diff --git a/print/acroread/files/patch-aa b/print/acroread/files/patch-aa
new file mode 100644
index 000000000000..1df7cbfd4124
--- /dev/null
+++ b/print/acroread/files/patch-aa
@@ -0,0 +1,32 @@
+--- INSTALL.orig Mon Jul 1 15:09:57 2002
++++ INSTALL Thu Aug 8 04:28:23 2002
+@@ -133,8 +133,10 @@
+ total=0
+ for i in $* ; do
+ if [ "$i" -a -f "$i" ] ; then
+- if [ `uname -s` = "Linux" ] ; then
++ if [ `uname -s` = "FreeBSD|Linux" ] ; then
+ size=`ls -lLn "$i" | ( read perm links owner group size date ; echo $size )`
++ elif [ `uname -s` = "FreeBSD" ] ; then
++ size=`ls -lL "$i" | ( read perm links owner group size date ; echo $size )`
+ else
+ size=`ls -lLon "$i" | ( read perm links owner size date ; echo $size )`
+ fi
+@@ -344,7 +346,7 @@
+ SearchPlatformTar="$3"
+ CustomPlatformTar="$4"
+
+- OutputLicense "$ReadLicense"
++# OutputLicense "$ReadLicense"
+ ReadLicense=""
+
+ PrintRequiredFree "$ReadTar" "$SearchTar" "$CustomTar" \
+@@ -524,7 +526,7 @@
+ ;;
+ esac
+ ;;
+- Linux)
++ FreeBSD)
+ ReadDefaultNum="$ReadIntelLinuxNum"
+ DefaultName="Intel/Linux"
+ ;;
diff --git a/print/acroread/pkg-deinstall b/print/acroread/pkg-deinstall
deleted file mode 100644
index 49b0cb2d89a3..000000000000
--- a/print/acroread/pkg-deinstall
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-rm -f ${PKG_PREFIX}/usr/bin/acroread7
-rm -f ${PKG_PREFIX}/usr/bin/acroread
diff --git a/print/acroread/pkg-descr b/print/acroread/pkg-descr
index 7b6f6561fa4d..ba2a664df766 100644
--- a/print/acroread/pkg-descr
+++ b/print/acroread/pkg-descr
@@ -4,5 +4,3 @@ you view, distribute, and print documents in Portable Document Format
used to create the original file. PDF files retain all the formatting,
fonts, and graphics of the original document, and virtually any
PostScript(TM) document can be converted into a PDF file.
-
-Use the "acroread7" command to run this program.
diff --git a/print/acroread/pkg-install b/print/acroread/pkg-install
deleted file mode 100644
index 368fbff2b52f..000000000000
--- a/print/acroread/pkg-install
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd ${PREFIX:-/usr/local}/bin ; ln -sf ${PKG_PREFIX}/usr/local/Adobe/Acrobat7.0/bin/acroread acroread7
-cd ${PREFIX:-/usr/local}/bin ; ln -sf ${PKG_PREFIX}/usr/local/Adobe/Acrobat7.0/bin/acroread acroread
diff --git a/print/acroread/pkg-plist b/print/acroread/pkg-plist
new file mode 100644
index 000000000000..63ddd6bd801a
--- /dev/null
+++ b/print/acroread/pkg-plist
@@ -0,0 +1,92 @@
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/autoIndx.api
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/search.api
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/acrosrch.uid
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome/vdk10.cmp
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome/vdk10.lic
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome/vdk10.std
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome/vdk10.syx
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome/language/acro20.lng
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome/language/vdk10.rsd
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome/language/vdk10.rst
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome/language/vdk10.stc
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome/language/vdk10.stp
+@comment ALPHA-ONLY:Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome/language/vdk10.syd
+Acrobat5/Browsers/netscape
+Acrobat5/Browsers/%%ARCHDIR%%/nppdf.so
+Acrobat5/Resource/Font/AdobeSansMM
+Acrobat5/Resource/Font/AdobeSansMM.MMM
+Acrobat5/Resource/Font/AdobeSerifMM
+Acrobat5/Resource/Font/AdobeSerifMM.MMM
+Acrobat5/Resource/Font/Arial
+Acrobat5/Resource/Font/Arial-Bold
+Acrobat5/Resource/Font/Arial-BoldItalic
+Acrobat5/Resource/Font/Arial-Italic
+Acrobat5/Resource/Font/Courier
+Acrobat5/Resource/Font/Courier-Bold
+Acrobat5/Resource/Font/Courier-BoldOblique
+Acrobat5/Resource/Font/Courier-Oblique
+Acrobat5/Resource/Font/Fonts14.upr
+Acrobat5/Resource/Font/Symbol
+Acrobat5/Resource/Font/TimesNewRoman
+Acrobat5/Resource/Font/TimesNewRoman-Bold
+Acrobat5/Resource/Font/TimesNewRoman-BoldItalic
+Acrobat5/Resource/Font/TimesNewRoman-Italic
+Acrobat5/Resource/Font/ZapfDingbats
+Acrobat5/Resource/LICFONT.TXT
+Acrobat5/Reader/AcroVersion
+Acrobat5/Reader/MapTypes.pdf
+Acrobat5/Reader/help/acrobat.pdf
+Acrobat5/Reader/help/reader.pdf
+@comment ALPHA-ONLY:Acrobat5/Reader/help/search.pdf
+Acrobat5/Reader/%%ARCHDIR%%/app-defaults/AcroRead
+Acrobat5/Reader/%%ARCHDIR%%/bin/acroread
+Acrobat5/Reader/%%ARCHDIR%%/lib/XKeysymDB
+Acrobat5/Reader/%%ARCHDIR%%/lib/libACE.so
+Acrobat5/Reader/%%ARCHDIR%%/lib/libACE.so.2.02
+Acrobat5/Reader/%%ARCHDIR%%/lib/libAGM.so
+Acrobat5/Reader/%%ARCHDIR%%/lib/libAGM.so.4.08
+Acrobat5/Reader/%%ARCHDIR%%/lib/libBIB.so
+Acrobat5/Reader/%%ARCHDIR%%/lib/libBIB.so.1.1
+Acrobat5/Reader/%%ARCHDIR%%/lib/libCoolType.so
+Acrobat5/Reader/%%ARCHDIR%%/lib/libCoolType.so.4.10
+Acrobat5/Reader/%%ARCHDIR%%/lib/libOPP.so
+Acrobat5/Reader/%%ARCHDIR%%/lib/libOPP.so.1.02
+Acrobat5/Reader/%%ARCHDIR%%/plug_ins/AcroForm.api
+Acrobat5/Reader/%%ARCHDIR%%/plug_ins/EScript.api
+Acrobat5/Reader/%%ARCHDIR%%/plug_ins/JavaScripts/AFStrENU.js
+Acrobat5/Reader/%%ARCHDIR%%/plug_ins/JavaScripts/AForm.js
+Acrobat5/Reader/%%ARCHDIR%%/plug_ins/Highlight.api
+Acrobat5/Reader/%%ARCHDIR%%/plug_ins/ewh.api
+Acrobat5/Reader/%%ARCHDIR%%/plug_ins/wwwlink.api
+Acrobat5/Reader/res/ENUtxt.pdf
+Acrobat5/Reader/res/splashScreen11R.xbm
+Acrobat5/Reader/res/splashScreen18R.xpm
+Acrobat5/Reader/license.txt
+Acrobat5/bin/acroread
+bin/acroread
+bin/acroread5
+%%PORTDOCS%%share/doc/acroread/README
+@exec ln -sf ../../Resource/Font/ %D/Acrobat5/Reader/%%ARCHDIR%%/fonts
+@unexec rm -f %D/Acrobat5/Reader/%%ARCHDIR%%/fonts
+@exec ln -sf ../res %D/Acrobat5/Reader/%%ARCHDIR%%/res
+@unexec rm -f %D/Acrobat5/Reader/%%ARCHDIR%%/res
+@exec echo "Be sure to read the license agreement in"
+@exec echo "%D/Acrobat5/Reader/license.txt"
+@dirrm Acrobat5/bin
+@dirrm Acrobat5/Reader/res
+@comment ALPHA-ONLY:@dirrm Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome/language
+@comment ALPHA-ONLY:@dirrm Acrobat5/Reader/%%ARCHDIR%%/plug_ins/vdkHome
+@dirrm Acrobat5/Reader/%%ARCHDIR%%/plug_ins/JavaScripts
+@dirrm Acrobat5/Reader/%%ARCHDIR%%/plug_ins
+@dirrm Acrobat5/Reader/%%ARCHDIR%%/lib
+@dirrm Acrobat5/Reader/%%ARCHDIR%%/bin
+@dirrm Acrobat5/Reader/%%ARCHDIR%%/app-defaults
+@dirrm Acrobat5/Reader/%%ARCHDIR%%
+@dirrm Acrobat5/Reader/help
+@dirrm Acrobat5/Reader
+@dirrm Acrobat5/Resource/Font
+@dirrm Acrobat5/Resource
+@dirrm Acrobat5/Browsers/%%ARCHDIR%%
+@dirrm Acrobat5/Browsers
+@dirrm Acrobat5
+@dirrm share/doc/acroread