aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/pdfcolorsplit/Makefile34
-rw-r--r--print/pdfcolorsplit/distinfo2
-rw-r--r--print/pdfcolorsplit/pkg-descr6
3 files changed, 42 insertions, 0 deletions
diff --git a/print/pdfcolorsplit/Makefile b/print/pdfcolorsplit/Makefile
new file mode 100644
index 000000000000..94f94c4152bf
--- /dev/null
+++ b/print/pdfcolorsplit/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pdfcolorsplit
+# Date created: 2011-08-26
+# Whom: Aldis Berjoza <aldis@bsdroot.lv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdfcolorsplit
+PORTVERSION= 2011.08.26
+CATEGORIES= print python
+MASTER_SITES= http://files.bsdroot.lv/my/FreeBSD/distfiles/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= aldis@bsdroot.lv
+COMMENT= Split your pdf into 2 pdf, color and bw, for printing
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= pdftk:${PORTSDIR}/print/pdftk \
+ pdftoppm:${PORTSDIR}/graphics/xpdf
+
+USE_GHOSTSCRIPT_RUN= YES
+USE_PYTHON= YES
+USE_XZ= YES
+
+PLIST_FILES= bin/${PORTNAME}
+
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/print/pdfcolorsplit/distinfo b/print/pdfcolorsplit/distinfo
new file mode 100644
index 000000000000..a847d61b21fa
--- /dev/null
+++ b/print/pdfcolorsplit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pdfcolorsplit-2011.08.26.tar.xz) = 1e15260ee74e626af0ee87ab909764d9cac6048f6ad82afc9ba3dc5f3da8b8e5
+SIZE (pdfcolorsplit-2011.08.26.tar.xz) = 2696
diff --git a/print/pdfcolorsplit/pkg-descr b/print/pdfcolorsplit/pkg-descr
new file mode 100644
index 000000000000..322950bb9b41
--- /dev/null
+++ b/print/pdfcolorsplit/pkg-descr
@@ -0,0 +1,6 @@
+pdfcolorsplit - a Python program that drives pdftk to split a PDF file into
+color and b/w parts. Useful for printing large documents with a few color pages
+when color printing is expensive. This program was inspired by Jeremy Sander's
+dvicoloursplit.py.
+
+WWW: http://homepages.inf.ed.ac.uk/imurray2/code/#pdfcolorsplit