aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/derelict-ft/Makefile37
-rw-r--r--print/derelict-ft/distinfo3
-rw-r--r--print/derelict-ft/pkg-descr4
-rw-r--r--print/derelict-ft/pkg-plist4
5 files changed, 49 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index c0ed27d779e6..ce5be0683681 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -31,6 +31,7 @@
SUBDIR += cups-pk-helper
SUBDIR += cups-smb-backend
SUBDIR += deforaos-pdfviewer
+ SUBDIR += derelict-ft
SUBDIR += detex
SUBDIR += dot2tex
SUBDIR += dvi2tty
diff --git a/print/derelict-ft/Makefile b/print/derelict-ft/Makefile
new file mode 100644
index 000000000000..36f91540dd8e
--- /dev/null
+++ b/print/derelict-ft/Makefile
@@ -0,0 +1,37 @@
+# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= derelict-ft
+PORTVERSION= 1.1.3
+CATEGORIES= print
+MASTER_SITES= https://github.com/DerelictOrg/DerelictFT/archive/
+DISTNAME= ${PORTVERSION:S/^/v/}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Dynamic binding to the FreeType library for the D lang
+
+LICENSE= BSL
+
+BUILD_DEPENDS= ldmd2:lang/ldc \
+ dub:devel/dub \
+ ${LOCALBASE}/lib/d/libDerelictUtil.a:devel/derelict-util
+
+WRKSRC= ${WRKDIR}/DerelictFT-${PORTVERSION}
+DUB_CMD= ${LOCALBASE}/bin/dub build --build=release
+D_INCLUDE_DIR= ${PREFIX}/include/d
+D_LIB_DIR= ${PREFIX}/lib/d
+
+post-patch:
+ @${REINPLACE_CMD} -e '13,15d' ${WRKSRC}/dub.json
+
+do-build:
+ @cd ${WRKSRC} && ${DUB_CMD}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${D_INCLUDE_DIR}
+ @${MKDIR} ${STAGEDIR}${D_LIB_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/lib/libDerelictFT.a ${STAGEDIR}${D_LIB_DIR}
+ cd ${WRKSRC}/source && ${COPYTREE_SHARE} . ${STAGEDIR}${D_INCLUDE_DIR} "-name *\.d"
+
+.include <bsd.port.mk>
diff --git a/print/derelict-ft/distinfo b/print/derelict-ft/distinfo
new file mode 100644
index 000000000000..3cf556663b3a
--- /dev/null
+++ b/print/derelict-ft/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1500698108
+SHA256 (derelict-ft/v1.1.3.tar.gz) = 135eae5d154c8537cff2e08267a22f58ee05f93f8b5f974016cde085c64c4ff7
+SIZE (derelict-ft/v1.1.3.tar.gz) = 22608
diff --git a/print/derelict-ft/pkg-descr b/print/derelict-ft/pkg-descr
new file mode 100644
index 000000000000..d9c83743e9c1
--- /dev/null
+++ b/print/derelict-ft/pkg-descr
@@ -0,0 +1,4 @@
+A dynamic binding to version 2.6 and 2.7 of the FreeType library for the D
+Programming Language
+
+WWW: https://github.com/DerelictOrg/DerelictFT
diff --git a/print/derelict-ft/pkg-plist b/print/derelict-ft/pkg-plist
new file mode 100644
index 000000000000..fd3bb7a0347f
--- /dev/null
+++ b/print/derelict-ft/pkg-plist
@@ -0,0 +1,4 @@
+include/d/derelict/freetype/ft.d
+include/d/derelict/freetype/functions.d
+include/d/derelict/freetype/types.d
+lib/d/libDerelictFT.a