aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/auctex/Makefile1
-rw-r--r--print/yatex-mule/Makefile1
-rw-r--r--print/yatex-xemacs-mule/Makefile1
-rw-r--r--print/yatex-xemacs/Makefile1
-rw-r--r--print/yatex/Makefile1
5 files changed, 5 insertions, 0 deletions
diff --git a/print/auctex/Makefile b/print/auctex/Makefile
index 144ab837576f..75dbf0723a7c 100644
--- a/print/auctex/Makefile
+++ b/print/auctex/Makefile
@@ -24,6 +24,7 @@ CONFIGURE_ARGS= --with-lispdir=${PREFIX}/${LISPDIR} \
--with-auto-dir=${PREFIX}/${LISPDIR}/auctex/auto \
--with-texmf-dir=${PREFIX}/${TEXMFDIR}
+USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
LISPDIR= ${EMACS_VERSION_SITE_LISPDIR}
diff --git a/print/yatex-mule/Makefile b/print/yatex-mule/Makefile
index f24d548aa015..1e3c66cbb906 100644
--- a/print/yatex-mule/Makefile
+++ b/print/yatex-mule/Makefile
@@ -10,6 +10,7 @@ PKGNAMESUFFIX= -mule
MASTERDIR= ${.CURDIR}/../yatex
COMMENT= Yet Another LaTeX mode and html mode on Emacs (for mule 2.3)
+USE_EMACS= yes
EMACS_PORT_NAME=mule
.include "${MASTERDIR}/Makefile"
diff --git a/print/yatex-xemacs-mule/Makefile b/print/yatex-xemacs-mule/Makefile
index 0a40fdf275ab..1c927b34c15e 100644
--- a/print/yatex-xemacs-mule/Makefile
+++ b/print/yatex-xemacs-mule/Makefile
@@ -10,6 +10,7 @@ PKGNAMESUFFIX= -xemacs-mule
MASTERDIR= ${.CURDIR}/../yatex
COMMENT= Yet Another LaTeX mode and html mode on Emacs (for XEmacs21-mule)
+USE_EMACS= yes
EMACS_PORT_NAME=xemacs21-mule
IGNORE= hangs during build
diff --git a/print/yatex-xemacs/Makefile b/print/yatex-xemacs/Makefile
index 0e4f35013136..76ef32c03456 100644
--- a/print/yatex-xemacs/Makefile
+++ b/print/yatex-xemacs/Makefile
@@ -10,6 +10,7 @@ PKGNAMESUFFIX= -xemacs
MASTERDIR= ${.CURDIR}/../yatex
COMMENT= Yet Another LaTeX mode and html mode on Emacs (for XEmacs21)
+USE_EMACS= yes
EMACS_PORT_NAME=xemacs21
.include "${MASTERDIR}/Makefile"
diff --git a/print/yatex/Makefile b/print/yatex/Makefile
index 69bcaee08226..6ec2888627a2 100644
--- a/print/yatex/Makefile
+++ b/print/yatex/Makefile
@@ -19,6 +19,7 @@ PKGDEINSTALL= ${WRKDIR}/DEINSTALL
PKGMESSAGE= ${WRKDIR}/MESSAGE
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+USE_EMACS= yes
EMACS_PORT_NAME?=emacs21
EMACS_NO_RUN_DEPENDS=YES
.if (${EMACS_PORT_NAME} != xemacs21-mule)