aboutsummaryrefslogtreecommitdiffstats
path: root/russian/p5-Convert-Cyrillic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'russian/p5-Convert-Cyrillic/Makefile')
-rw-r--r--russian/p5-Convert-Cyrillic/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/russian/p5-Convert-Cyrillic/Makefile b/russian/p5-Convert-Cyrillic/Makefile
new file mode 100644
index 000000000000..326e24252a1e
--- /dev/null
+++ b/russian/p5-Convert-Cyrillic/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Convert-Cyrillic
+# Date created: 07 May 2009
+# Whom: Sergey Kandaurov <pluknet@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Convert-Cyrillic
+PORTVERSION= 1.05
+CATEGORIES= russian converters perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= cyrillic-${PORTVERSION}
+
+MAINTAINER= pluknet@gmail.com
+COMMENT= Routines for converting from one cyrillic charset to another
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unicode/Map8.pm:${PORTSDIR}/converters/p5-Unicode-Map8
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Convert::Cyrillic.3 \
+ Lingua::DetectCharset.3
+
+.include <bsd.port.mk>
>-0/+89 * - fix pkg-plistrm2013-05-122-10/+6 * - Update to 2.23zi2013-05-122-8/+7 * Horde update (introducing MongoDB support):mm2013-05-112-3/+3 * Switch to libnet10 by default.wxs2013-05-111-3/+3 * - Update to 0.2.1miwi2013-05-102-4/+4 * - update to 0.71jgh2013-05-102-3/+3 * Update py-impacket to 0.9.10antoine2013-05-094-14/+37 * Update to 21.fjoe2013-05-092-3/+3 * - update to 0.70jgh2013-05-092-3/+3 * - Update to 0.8.13zi2013-05-093-7/+8 * Mark MAKE_JOBS_SAFEehaupt2013-05-081-0/+1 * Add forgotten birdcl (lightweight client) to plist.melifaro2013-05-082-0/+2 * Update net/bird && net/bird6 to 1.3.10.melifaro2013-05-085-37/+6 * - Update to 1.4.0bdrewery2013-05-072-4/+4 * Update to 1.13.tobez2013-05-072-4/+4 * Update to 4.131(.)260.tobez2013-05-072-3/+3 * Convert USE_NCURSES by USES=ncursesbapt2013-05-061-6/+3 * Update to 3.06.tobez2013-05-062-8/+4 * Update to 2.36.tobez2013-05-062-7/+7 * Fix typobapt2013-05-061-1/+1 * Convert from WITHOUT_NLS to PORT_OPTIONS:MNLSbapt2013-05-0611-98/+86 * Update to 1.4.0.wxs2013-05-062-5/+4 * Fix the build when netatalk3 is already installed.marcus2013-05-061-1/+10 * Fix installation of ports that rely on cp -n for installing files. r245960flo2013-05-052-2/+2 * Add some missing options to OPTIONS_DEFINEmarcus2013-05-051-1/+2 * Mark as broken: does not fetchbapt2013-05-051-0/+2 * Fix build when flac is compiled WITHOUT_NLScrees2013-05-053-1/+12 * - Trim old-style header.hrs2013-05-041-6/+8 * Wireshark always needs pkgconf (this fixes wireshark-lite)bapt2013-05-041-2/+1 * Fix build on currentbapt2013-05-042-10/+6 * New port: tcpsplitantoine2013-05-044-0/+39 * - Update to 3.3.2.hrs2013-05-0413-111/+77 * Chase security/libgcrypt updateehaupt2013-05-0415-40/+25 * Fix build with bmake by using gmake if make is bmakebapt2013-05-031-0/+3 * Upstream makefile is not bmake compatible, let's use gmake to build this port...bapt2013-05-031-0/+4 * Fix with bmake(1)bapt2013-05-031-1/+1 * Fix WWW.sobomax2013-05-031-1/+1 * Add p5-Net-Syslog - a perl extension for sending syslog messages to a remotesobomax2013-05-035-0/+34 * Fix typo.cy2013-05-033-3/+3 * Please bmake(1) as well as make(1)bapt2013-05-022-16/+7 * - Update to 0.52culot2013-05-023-4/+5 * Update to version 3.3pawel2013-05-025-121/+34 * - Update to 1.12culot2013-05-022-3/+3 * Update to 4.131(.)210.tobez2013-05-022-3/+3 * Update to 0.06.tobez2013-05-023-4/+6 * Update to 0.19.tobez2013-05-012-4/+3 * - Update to 1.1.6tota2013-05-012-5/+4 * - Mark MAKE_JOBS_UNSAFEbdrewery2013-05-011-0/+1 * Add licence info to some portscrees2013-05-012-5/+7 * - Fix dependency on net-snmp; net-snmp4 was removed inbdrewery2013-05-011-1/+1 * - conversion of USE_GETTEXT to USES frameworkjgh2013-05-014-33/+27 * - Trim headermiwi2013-04-301-8/+5 * - Trim headermiwi2013-04-301-8/+4 * - Convert to PEAR_AUTOINSTALLmiwi2013-04-301-7/+5 * - Depend on textproc/rubygem-libxml-ruby instead of textproc/ruby-libxml. Thegahr2013-04-301-1/+2 * - Update MASTER_SITESmiwi2013-04-301-11/+10 * Unbreak py-impacket on FreeBSD 8.3antoine2013-04-301-2/+2 * - Update to 5.0nivit2013-04-304-755/+1192 * Run rc.d scripts before NETWORKING, not LOGIN, since that is too late.stefan2013-04-292-2/+2 * Update to 4.00005.tobez2013-04-292-3/+3 * Rely on bsdtar to autodetermine the format of the distfiles when possiblebapt2013-04-296-15/+8 * Update to 4.0.4.26marcus2013-04-2913-192/+67 * Correct a typo.marcus2013-04-291-1/+1 * Update to 3.0.3 and port to using OptionsNG.marcus2013-04-294-30/+48 * - Fix error with VLAN interfaces on recent FreeBSD versions [1]stefan2013-04-294-10/+23 * Update py-impacket to 0.9.9.9antoine2013-04-294-29/+106 * Unbreak and update py-pcapy to 0.10.8antoine2013-04-293-23/+28 * Add MAKE_JOBS_SAFE=yes.hrs2013-04-291-0/+1 * - Add LICENSE.hrs2013-04-292-10/+12 * Add Gstreamer 1.0.7. This is the new stable version of thekwm2013-04-282-0/+14 * - Update to 1.6olivierd2013-04-283-13/+78 * - Convert USE_ICONV=yes to USES=iconvmva2013-04-2731-44/+33 * - Update to 1.3.5madpilot2013-04-272-8/+4 * - Update to 0.21sunpoet2013-04-272-4/+4 * HTTPS client for httplib and urllib2 based on PyOpenSSL.olivierd2013-04-275-0/+89 * - Remove bogus variableak2013-04-261-1/+0 * Update to 1.2.8.stefan2013-04-262-3/+3 * Remove USE_CDRTOOLS from bsd.port.mkbapt2013-04-261-9/+6 * - Convert USE_GETTEXT to USES (part 4)ak2013-04-265-8/+5 * Update MASTERSITES for my server to use httpsgjb2013-04-261-1/+1 * Update to 0.12.4.novel2013-04-252-3/+3 * Update to version 4.2.54pawel2013-04-253-3/+4 * - Convert USE_GETTEXT to USES (part 3)ak2013-04-2542-42/+42 * - Use bsd.port.options.mk.olgeni2013-04-251-5/+3 * Fix formatting of WWW line for my portseadler2013-04-251-1/+1 * - Convert USE_GETTEXT to USES (part 1)ak2013-04-242-4/+2 * Modernize the port:mi2013-04-244-3/+20 * Unbreak -- compiles here (9.1/amd64). While at it, patch the ancientmi2013-04-247-36/+197 * Update to 1.25.23garga2013-04-244-33/+34 * Finish converting the whole ports tree to USES=pkgconfigbapt2013-04-2334-89/+42 * - Add version number to application path.olgeni2013-04-232-45/+52 * - Remove lang/tcl83 and x11-toolkits/tk83 (expired)gahr2013-04-231-1/+1 * Fix loop detection bug.des2013-04-232-0/+11 * Convert my ports to use the new USES=pkgconfigbapt2013-04-231-2/+2 * - Update to 3.1.10zi2013-04-232-3/+3 * - update net/asterisk to 1.8.21.0flo2013-04-2312-41/+46 * - Update EFL libraries to 1.7.6(.1)gblach2013-04-232-4/+4 * - Update to 0.20sunpoet2013-04-232-3/+3 * - Add timestamps option (used by netperf-wrapper) [1]ak2013-04-223-7/+30 * Horde ports update:mm2013-04-222-3/+3 * - Add missing USE_PKGCONFIG=buildsunpoet2013-04-221-0/+1 * - Add missing USE_PKGCONFIG=buildsunpoet2013-04-221-0/+1 * - Add missing USE_PKGCONFIG=buildsunpoet2013-04-221-0/+1 * - Add missing USE_PKGCONFIG=buildsunpoet2013-04-221-0/+1 * - Update to 0.2.2 and unbreak this portsunpoet2013-04-222-13/+12 * Update to 1.2.1.netchild2013-04-202-3/+3 * Fix typos in pkg-descr.olgeni2013-04-201-2/+2 * Fix whitespace in pkg-descr.olgeni2013-04-201-1/+1 * Fix a typo in pkg-descr.olgeni2013-04-201-1/+1 * - update to 1.0.5 [1]jgh2013-04-194-12/+60 * - Update to 0.54culot2013-04-193-13/+21 * - update to 0.63jgh2013-04-192-4/+3 * Vortex is a near real time IDS and network surveillance engine for TCP streamwxs2013-04-187-0/+91 * - Update to 2.0.2martymac2013-04-182-8/+4 * - Make fftw3 support optional from NCURSES supportehaupt2013-04-181-4/+19 * - Fix the build if old freerdp exists in the systemfluffy2013-04-181-3/+1 * - Update to 4.2.5P1zi2013-04-1810-82/+21 * Update to 2.2.1. This is a bugfix release including upstream imported FreeBSDehaupt2013-04-183-41/+13 * - Update to 2.2ehaupt2013-04-183-9/+42 * - Move distfile to PECL directorysunpoet2013-04-182-7/+4 * - update to 4.1.3 to fix zope runtime after zope.security updaterm2013-04-183-35/+34 * - Update to 0.20.2sunpoet2013-04-182-3/+3 * Mark as broken, does not build:bapt2013-04-171-0/+2 * - update to 0.62jgh2013-04-173-9/+35 * Update to 2.4.35.delphij2013-04-173-11/+11 * Update to 2.82crees2013-04-174-102/+26 * - Update to 0.83bdrewery2013-04-172-9/+5 * - Update to 0.55sunpoet2013-04-172-3/+3 * - Fix PLISTsunpoet2013-04-171-1/+1 * - Take MAINTAINERshipzi2013-04-162-10/+11 * Remove expired ports:rene2013-04-1610-114/+0 * - Add mirror as main site is not workingbdrewery2013-04-111-1/+2 * - complete optionsNG conversionjgh2013-04-093-44/+32 * - Update to digiKam and Kipi Plugins ports to 3.1.0makc2013-04-092-10/+3 * - Convert to OptionsNG.cy2013-04-086-165/+333 * Fix build.wxs2013-04-031-1/+1 * Update to version 1.5-dev18.demon2013-04-032-3/+3 * Update to version 1.4.23.demon2013-04-032-4/+3 * - Update MASTER_SITESmiwi2013-04-031-14/+19 * Switch to USE_PKGCONFIG=build (old habits die hard).marcus2013-03-311-1/+2 * Make pkgconfig an explicit dependency of tshark.marcus2013-03-311-1/+1 * - Unbreak buildmiwi2013-03-302-2/+9 * - Unbreak buildmiwi2013-03-302-2/+1 * GNU Emacs updatesashish2013-03-301-0/+1 * - Update Haskell ports from the development repositorypgj2013-03-3015-15/+57 * - Update net/usbredir to 0.6 .nox2013-03-304-8/+8 * Update to the 0.1.3 version.timur2013-03-303-5/+6 * Update asterisk ports to:flo2013-03-296-9/+9 * - Update to 0.54sunpoet2013-03-292-3/+3 * - update to 0.99.22rm2013-03-295-59/+49 * This does a basic check if something is a perl script or not.miwi2013-03-29