aboutsummaryrefslogtreecommitdiffstats
path: root/science/brian/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/brian/Makefile')
-rw-r--r--science/brian/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/science/brian/Makefile b/science/brian/Makefile
new file mode 100644
index 000000000000..f78024406bd5
--- /dev/null
+++ b/science/brian/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: brian
+# Date created: 27 Feb, 2009
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= brian
+PORTVERSION= 1.1.2
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP \
+ SF
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A clock-driven simulator for spiking neural networks
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.1.0:${PORTSDIR}/math/py-numpy \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.6.0:${PORTSDIR}/science/py-scipy \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_ZIP= yes
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>