aboutsummaryrefslogtreecommitdiffstats
path: root/science/cgnslib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/cgnslib/Makefile')
-rw-r--r--science/cgnslib/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/science/cgnslib/Makefile b/science/cgnslib/Makefile
index d4a79cc9e6c7..2214f573c7a3 100644
--- a/science/cgnslib/Makefile
+++ b/science/cgnslib/Makefile
@@ -52,7 +52,7 @@ TESTSBIN= cgwrite cgread test_partial
.if ${PORT_OPTIONS:MTOOLS}
USES+= tk
USE_GL= gl glu
-USE_XORG= xmu
+USE_XORG= x11 xmu
CMAKE_ARGS+= -DCGNS_BUILD_CGNSTOOLS:BOOL=TRUE \
-DTCL_INCLUDE_PATH:STRING="${TCL_INCLUDEDIR}" \
-DTK_INCLUDE_PATH:STRING="${TK_INCLUDEDIR}"
@@ -63,12 +63,10 @@ PLIST_SUB= TOOLS="@comment "
LIBVER= ${PORTVERSION:R}
-.if ${PORT_OPTIONS:MTESTS}
-regression-test:
-. for pg in ${TESTSBIN}
+do-test-TESTS-on:
+.for pg in ${TESTSBIN}
@(cd ${BUILD_WRKSRC}/src/tests; ./${pg})
-. endfor
-.endif
+.endfor
post-install:
${LN} -sf libcgns.so.${LIBVER} ${STAGEDIR}${PREFIX}/lib/libcgns.so.${LIBVER:R}