aboutsummaryrefslogtreecommitdiffstats
path: root/science/chemtool-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/chemtool-devel/Makefile')
-rw-r--r--science/chemtool-devel/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/science/chemtool-devel/Makefile b/science/chemtool-devel/Makefile
index 6ca47cfcdb10..cae93cd6c504 100644
--- a/science/chemtool-devel/Makefile
+++ b/science/chemtool-devel/Makefile
@@ -1,30 +1,34 @@
-# New ports collection makefile for: chemtool
-# Date created: Mar 5, 2003
+# New ports collection makefile for: chemtool-devel
+# Date created: Mar 5, 2003
# Whom: NAKATA, Maho <maho@FreeBSD.org>
#
# $FreeBSD$
PORTNAME= chemtool
-PORTVERSION= 1.6
+PORTVERSION= 1.6.1
CATEGORIES= science
MASTER_SITES= http://ruby.chemie.uni-freiburg.de/~martin/chemtool/
-DISTNAME= ct16a29
+DISTNAME= ct161gtk2
EXTRACT_SUFX= .tgz
MAINTAINER= maho@FreeBSD.org
-COMMENT= Drawing organic molecules easily and store them (develop version)
+COMMENT= Drawing organic molecules easily and store them (developer version)
+LIB_DEPENDS= EMF.1:${PORTSDIR}/graphics/libemf
RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}alpha29
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-gtk2/
USE_REINPLACE= yes
USE_GTK= yes
+USE_AUTOCONF= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+CONFIGURE_ARGS= --enable-emf=yes
+PKGNAMESUFFIX= -devel
MAN1= chemtool.1 cht.1
-do-build:
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE})
+post-patch:
+ ${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/Makefile.in
do-install:
@(cd ${WRKSRC}; ${GMAKE} install)