aboutsummaryrefslogtreecommitdiffstats
path: root/science/clipper/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/clipper/Makefile')
-rw-r--r--science/clipper/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/science/clipper/Makefile b/science/clipper/Makefile
new file mode 100644
index 000000000000..7d4ba57dddbb
--- /dev/null
+++ b/science/clipper/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= clipper
+DISTVERSION= 2.1.20180526
+CATEGORIES= science
+MASTER_SITES= https://www2.mrc-lmb.cam.ac.uk/personal/pemsley/coot/dependencies/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Libraries for the organisation of crystallographic data
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libccp4c.so:science/libccp4 \
+ libmmdb2.so:science/mmdb2 \
+ libsfftw.so:math/fftw-float
+
+USES= fortran gmake libtool localbase:ldflags
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-shared --disable-static \
+ --enable-phs --enable-cns --enable-mmdb --enable-minimol --enable-cif --enable-ccp4 --enable-fortran
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/\.[0-9]+$//}
+
+.include <bsd.port.mk>