aboutsummaryrefslogtreecommitdiffstats
path: root/science/gchempaint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/gchempaint/Makefile')
-rw-r--r--science/gchempaint/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/science/gchempaint/Makefile b/science/gchempaint/Makefile
index 013534d11c16..4afede99454e 100644
--- a/science/gchempaint/Makefile
+++ b/science/gchempaint/Makefile
@@ -5,28 +5,31 @@
# $FreeBSD$
PORTNAME= gchempaint
-PORTVERSION= 0.6.9
-PORTREVISION= 1
+PORTVERSION= 0.8.0
CATEGORIES= science
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= ${PORTNAME}/0.6
+MASTER_SITE_SUBDIR= ${PORTNAME}/0.8
MAINTAINER= pav@FreeBSD.org
COMMENT= 2D chemical structures editor for GNOME 2
BUILD_DEPENDS= gnome-doc-prepare:${PORTSDIR}/textproc/gnome-doc-utils
-LIB_DEPENDS= gcu.6:${PORTSDIR}/science/gchemutils
+LIB_DEPENDS= gcu.8:${PORTSDIR}/science/gchemutils
USE_BZIP2= yes
USE_XLIB= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
-GCONF_SCHEMAS= gchempaint-arrows.schemas
-USE_GNOME= gnomehack gnomeprefix intlhack libgnomeprintui libgnomeui
+GCONF_SCHEMAS= gchempaint.schemas gchempaint-arrows.schemas
+USE_GNOME= gnomehack intlhack libgnomeprintui libgnomeui
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-help-dir=${PREFIX}/share/gnome/help
+CONFIGURE_ARGS= --with-help-dir=${PREFIX}/share/gnome/help --with-omf-dir=${PREFIX}/share/gnome/omf
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-release $$(VERSION)|-version @GCP_VERSION_INFO@|' \
+ ${WRKSRC}/lib/Makefile.in ${WRKSRC}/libgcpcanvas/Makefile.in
.include <bsd.port.mk>