aboutsummaryrefslogtreecommitdiffstats
path: root/science/gchempaint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/gchempaint/Makefile')
-rw-r--r--science/gchempaint/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/science/gchempaint/Makefile b/science/gchempaint/Makefile
index ef981a1c9753..58e65e8a0c84 100644
--- a/science/gchempaint/Makefile
+++ b/science/gchempaint/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= gchempaint
-PORTVERSION= 0.4.4
+PORTVERSION= 0.4.5
CATEGORIES= science
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,6 +20,11 @@ USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix intlhack libgnomeprintui libgnomeui lthack
USE_GMAKE= yes
USE_LIBTOOL_VER=13
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(datadir)/mime/|${PREFIX}/share/mime/|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|$$(datadir)/mime$$|${PREFIX}/share/mime|' ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>