aboutsummaryrefslogtreecommitdiffstats
path: root/science/gwyddion/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/gwyddion/Makefile')
-rw-r--r--science/gwyddion/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/science/gwyddion/Makefile b/science/gwyddion/Makefile
index 3b860b5af8ef..c7c76d0aa98c 100644
--- a/science/gwyddion/Makefile
+++ b/science/gwyddion/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gwyddion
-PORTVERSION= 2.9
-PORTREVISION= 3
+PORTVERSION= 2.16
CATEGORIES= science graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,15 +17,14 @@ PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
MAINTAINER= yeti@gwyddion.net
COMMENT= A gtk2 based SPM data visualization and analysis tool
-LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
- gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext \
+LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext \
fftw3.5:${PORTSDIR}/math/fftw3
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${PREFIX}/share/doc \
- --disable-pascal --disable-pygwy
+ --disable-pascal --disable-pygwy --without-kde4-thumbnailer
MAKE_ARGS= pkgconfigdatadir=${PREFIX}/libdata/pkgconfig
@@ -40,7 +38,7 @@ USE_RUBY= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-MAN1= gwyddion.1
+MAN1= gwyddion.1 gwyddion-thumbnailer.1
MAN3= Gwyddion::dump.3pm
.if defined(WITHOUT_NLS)
@@ -51,6 +49,11 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+.if !defined(WITHOUT_GCONF) || exists(${LOCALBASE}/bin/gconftool-2)
+USE_GNOME+= gconf2
+GCONF_SCHEMAS= gwyddion-thumbnailer.schemas
+.endif
+
# Fix shared library versioning and inhibit installation of .la files manually.
# Ports libtool + ltverhack fixes versions but it installs static versions of
# modules, so one would have to hack it too.