aboutsummaryrefslogtreecommitdiffstats
path: root/science/kst2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/kst2/Makefile')
-rw-r--r--science/kst2/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index ad06f237d17a..8ce7b02f3a73 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -2,28 +2,32 @@
# $FreeBSD$
PORTNAME= kst
-DISTVERSION= 2.0.6
-PORTREVISION= 7
+DISTVERSION= 2.0.8
CATEGORIES= science kde
MASTER_SITES= SF/${PORTNAME}/Kst%20${DISTVERSION:C/-r.*//}/
+DISTNAME= Kst-${DISTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= Data viewing and plotting tool
LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
-USES= cmake pkgconfig
-USE_QT4= gui xml designer svg opengl \
+USES= cmake:outsource pkgconfig
+_USE_QT4= gui xml designer svg linguist_build \
qmake_build moc_build rcc_build uic_build
+_USE_QT5= concurrent network printsupport widgets xml \
+ buildtools_build linguisttools_build qmake_build
USE_LDCONFIG= yes
-CMAKE_SOURCE_PATH= ${WRKSRC}/cmake
CMAKE_ARGS+= -Dkst_install_prefix=${PREFIX} \
-Dkst_pch=off
PLIST_SUB= SHLIB_VER=${PORTVERSION}
OPTIONS_DEFINE= FITS MATLAB NETCDF
+OPTIONS_SINGLE= TOOLKIT
+OPTIONS_SINGLE_TOOLKIT= QT4 QT5
+OPTIONS_DEFAULT= QT4
OPTIONS_SUB= yes
FITS_DESC= Support for data in FITS format
@@ -35,6 +39,11 @@ MATLAB_LIB_DEPENDS= libmatio.so:${PORTSDIR}/math/matio
NETCDF_DESC= Support for data in NetCDF format
NETCDF_LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf
+TOOLKIT_DESC= Qt toolkit
+QT4_USE= ${_USE_QT4:S/^/QT4=/}
+QT5_USE= ${_USE_QT5:S/^/QT5=/}
+QT5_CMAKE_ON= -Dkst_qt5=on
+
.include <bsd.port.options.mk>
post-patch: