aboutsummaryrefslogtreecommitdiffstats
path: root/science/mpb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/mpb/Makefile')
-rw-r--r--science/mpb/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/science/mpb/Makefile b/science/mpb/Makefile
index 00ff1d4f847d..7915b427030e 100644
--- a/science/mpb/Makefile
+++ b/science/mpb/Makefile
@@ -12,11 +12,11 @@ COMMENT= MIT Photonic-Bands
LICENSE= GPLv2
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= libfftw.so:${PORTSDIR}/math/fftw \
- libhdf5.so:${PORTSDIR}/science/hdf5 \
- libctl.so:${PORTSDIR}/science/libctl \
- libguile-2.0.so:${PORTSDIR}/lang/guile2
+BUILD_DEPENDS= bash:shells/bash
+LIB_DEPENDS= libfftw.so:math/fftw \
+ libhdf5.so:science/hdf5 \
+ libctl.so:science/libctl \
+ libguile-2.0.so:lang/guile2
OPTIONS_DEFINE= ATLAS NLOPT
ATLAS_DESC= Use math/atlas instead of math/lapack
@@ -29,16 +29,16 @@ MAKE_JOBS_UNSAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NLOPT_LIB_DEPENDS= libnlopt.so:${PORTSDIR}/math/nlopt
+NLOPT_LIB_DEPENDS= libnlopt.so:math/nlopt
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MATLAS}
-LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:math/atlas
CONFIGURE_ARGS+= --with-lapack=-lalapack
.else
-LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas \
- liblapack.so:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:math/blas \
+ liblapack.so:math/lapack
CONFIGURE_ARGS+= --with-lapack=-llapack
.endif