aboutsummaryrefslogtreecommitdiffstats
path: root/science/p5-Chemistry-Reaction/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/p5-Chemistry-Reaction/Makefile')
-rw-r--r--science/p5-Chemistry-Reaction/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/science/p5-Chemistry-Reaction/Makefile b/science/p5-Chemistry-Reaction/Makefile
new file mode 100644
index 000000000000..03ee9721f5e5
--- /dev/null
+++ b/science/p5-Chemistry-Reaction/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Chemistry-Reaction
+# Date created: 2010-03-10
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chemistry-Reaction
+PORTVERSION= 0.02
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IT/ITUB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steve@mouf.net
+COMMENT= Represent a ring as a substructure of a molecule
+
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/File/SMILES.pm:${PORTSDIR}/science/p5-Chemistry-File-SMILES \
+ ${SITE_PERL}/Statistics/Regression.pm:${PORTSDIR}/math/p5-Statistics-Regression \
+ ${SITE_PERL}/Chemistry/Pattern.pm:${PORTSDIR}/science/p5-Chemistry-Pattern
+RUN_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/File/SMILES.pm:${PORTSDIR}/science/p5-Chemistry-File-SMILES \
+ ${SITE_PERL}/Statistics/Regression.pm:${PORTSDIR}/math/p5-Statistics-Regression \
+ ${SITE_PERL}/Chemistry/Pattern.pm:${PORTSDIR}/science/p5-Chemistry-Pattern
+
+MAN3= Chemistry::Reaction.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>