aboutsummaryrefslogtreecommitdiffstats
path: root/science/py-mdp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/py-mdp/Makefile')
-rw-r--r--science/py-mdp/Makefile33
1 files changed, 28 insertions, 5 deletions
diff --git a/science/py-mdp/Makefile b/science/py-mdp/Makefile
index 54d283f8b87a..2b33b64ef7c4 100644
--- a/science/py-mdp/Makefile
+++ b/science/py-mdp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mdp
-PORTVERSION= 2.4
-PORTREVISION= 1
+PORTVERSION= 3.2
CATEGORIES= science python
MASTER_SITES= SF/${PORTNAME}-toolkit/${PORTNAME}-toolkit/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,10 +15,34 @@ DISTNAME= ${PORTNAME:U}-${PORTVERSION}
MAINTAINER= llwang@infor.org
COMMENT= Modular toolkit for Data Processing
-RUN_DEPENDS= ${PYNUMPY} \
- ${PYTHON_SITELIBDIR}/scipy/__init__.py:${PORTSDIR}/science/py-scipy \
- ${PYTHON_SITELIBDIR}/symeig/__init__.py:${PORTSDIR}/math/py-symeig
+LICENSE= BSD
+RUN_DEPENDS= ${PYNUMPY}
+
+OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
+
+OPTIONS_DEFINE= LIBSVM PP SCIPY
+
+LIBSVM_DESC= Provide the LibSVMClassifier node
+PP_DESC= Provide the Parallel Python PPScheduler
+SCIPY_DESC= Instal SciPy versions of eigensolver, FFT and convolution
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MLIBSVM}
+RUN_DEPENDS+= libsvm>2.91:${PORTSDIR}/science/libsvm \
+ libsvm-python>2.91:${PORTSDIR}/science/libsvm-python
+.endif
+
+.if ${PORT_OPTIONS:MPP}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pp>0:${PORTSDIR}/devel/py-pp
+.endif
+
+.if ${PORT_OPTIONS:MSCIPY}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}scipy>=0.5.2:${PORTSDIR}/science/py-scipy
+.endif
+
+#Python3 ready
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
PYDISTUTILS_EGGINFO= ${PYDISTUTILS_PKGNAME:C/[^A-Za-z0-9.]+/_/g:U}-${PYDISTUTILS_PKGVERSION:C/[^A-Za-z0-9.]+/_/g}-${PYTHON_VERSION:S/thon//}.egg-info