aboutsummaryrefslogtreecommitdiffstats
path: root/science/svmlight/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/svmlight/Makefile')
-rw-r--r--science/svmlight/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/science/svmlight/Makefile b/science/svmlight/Makefile
index 4889daa4ffdc..3494bbf9e988 100644
--- a/science/svmlight/Makefile
+++ b/science/svmlight/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= science
MASTER_SITES= http://kodiak.cs.cornell.edu/svm_light/current/
DISTNAME= svm_light
-PATCH_SITES= http://search.cpan.org/src/KWILLIAMS/Algorithm-SVMLight-0.05/
+PATCH_SITES= http://search.cpan.org/src/KWILLIAMS/Algorithm-SVMLight-0.08/
PATCHFILES= SVMLight.patch
MAINTAINER= gslin@gslin.org
@@ -26,6 +26,13 @@ NO_WRKSUBDIR= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
+pre-patch:
+ ${CP} ${DISTDIR}/${PATCHFILES} ${WRKDIR}
+ ${REINPLACE_CMD} -e 's|svm_light/||g' ${WRKDIR}/${PATCHFILES}
+
+do-patch:
+ cd ${WRKDIR} && ${PATCH} < ${PATCHFILES}
+
post-build:
${CC} ${CFLAGS} -shared -o ${WRKSRC}/libsvmlight.so.1 \
${WRKSRC}/svm_common.o ${WRKSRC}/svm_hideo.o \