aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/abinit/Makefile4
-rw-r--r--science/afni/Makefile2
-rw-r--r--science/getdp/Makefile3
-rw-r--r--science/gnudatalanguage/Makefile4
-rw-r--r--science/gromacs/Makefile1
-rw-r--r--science/kst2/Makefile3
-rw-r--r--science/py-mlpy/Makefile4
-rw-r--r--science/step/Makefile3
8 files changed, 14 insertions, 10 deletions
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
index 00f32524e02f..03d83a55927a 100644
--- a/science/abinit/Makefile
+++ b/science/abinit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= abinit
PORTVERSION= 5.7.3
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= science
MASTER_SITES= ftp://ftp.abinit.org/pub/abinitio/ABINIT_v${PORTVERSION}/
@@ -16,7 +16,7 @@ COMMENT= Abinit calculates electronic structure of systems
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
LIB_DEPENDS= netcdff.4:${PORTSDIR}/science/netcdf3-ftn \
- gsl.16:${PORTSDIR}/math/gsl
+ gsl:${PORTSDIR}/math/gsl
USE_FORTRAN= yes
USE_GMAKE= yes
diff --git a/science/afni/Makefile b/science/afni/Makefile
index dc4605b41efe..c4fa87eabc1e 100644
--- a/science/afni/Makefile
+++ b/science/afni/Makefile
@@ -11,7 +11,7 @@
PORTNAME= afni
PORTVERSION= 2012.04.17.2129
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science biology graphics
MASTER_SITES= http://personalpages.tds.net/~jwbacon/Ports/distfiles/AFNI/${PORTVERSION}/ \
http://www.acadix.biz/Ports/distfiles/AFNI/${PORTVERSION}/
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
index 88d36bfa38ae..19fdaba1a79d 100644
--- a/science/getdp/Makefile
+++ b/science/getdp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= getdp
PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://www.geuz.org/getdp/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -11,7 +12,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= stephen@FreeBSD.org
COMMENT= A rather general finite element solver using mixed finite elements
-LIB_DEPENDS= gsl.16:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl \
lapack.4:${PORTSDIR}/math/lapack
USE_GMAKE= yes
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index eb780e01f7d4..26153795ac5d 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnudatalanguage
DISTVERSION= 0.9.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science lang
MASTER_SITES= SF/${PORTNAME}/gdl/${DISTVERSION}
.if defined(BUILD_PYTHON_MODULE)
@@ -30,7 +30,7 @@ LICENSE= GPLv2
LIB_DEPENDS+= plplotd.11:${PORTSDIR}/math/plplot \
ps.4:${PORTSDIR}/print/pslib \
- gsl.16:${PORTSDIR}/math/gsl \
+ gsl:${PORTSDIR}/math/gsl \
dps.0:${PORTSDIR}/x11/dgs
USE_GCC= yes
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index cfbd380f5785..52e69e87ce1c 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gromacs
PORTVERSION= 4.6.3
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 9bb7230fe662..bdba23cede4a 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -3,13 +3,14 @@
PORTNAME= kst
DISTVERSION= 2.0.6
+PORTREVISION= 1
CATEGORIES= science kde
MASTER_SITES= SF/${PORTNAME}/Kst%20${DISTVERSION:C/-r.*//}/
MAINTAINER= makc@FreeBSD.org
COMMENT= Data viewing and plotting tool
-LIB_DEPENDS= gsl.16:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
LATEST_LINK= kst2
diff --git a/science/py-mlpy/Makefile b/science/py-mlpy/Makefile
index fd79813a6d0e..db845410671d 100644
--- a/science/py-mlpy/Makefile
+++ b/science/py-mlpy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mlpy
PORTVERSION= 2.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science python
MASTER_SITES= https://mlpy.fbk.eu/download/src/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,7 +19,7 @@ COMMENT= High performance Python package for predictive modeling
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
cython>0:${PORTSDIR}/lang/cython
RUN_DEPENDS:= ${BUILD_DEPENDS}
-LIB_DEPENDS= gsl.16:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
CFLAGS+= -I${LOCALBASE}/include -I${PYTHON_SITELIBDIR}/numpy/core
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/science/step/Makefile b/science/step/Makefile
index 95a50a99659b..2a02f2859ec9 100644
--- a/science/step/Makefile
+++ b/science/step/Makefile
@@ -2,6 +2,7 @@
PORTNAME= step
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= science kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -11,7 +12,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 interactive physics simulator
LIB_DEPENDS= qalculate.5:${PORTSDIR}/math/libqalculate \
- gsl.16:${PORTSDIR}/math/gsl
+ gsl:${PORTSDIR}/math/gsl
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2