aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/ghemical/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/science/ghemical/Makefile b/science/ghemical/Makefile
index 291a6dbd2755..de979ac1f50c 100644
--- a/science/ghemical/Makefile
+++ b/science/ghemical/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
LIB_DEPENDS= gtkgl:${PORTSDIR}/x11-toolkits/gtkglarea \
glade-gnome:${PORTSDIR}/devel/libglade
+BROKEN= "Does not compile"
+
USE_GMAKE= yes
USE_REINPLACE= yes
USE_GTK= yes
@@ -29,12 +31,6 @@ CONFIGURE_ARGS= --enable-mpqc
USE_AUTOCONF= yes
USE_AUTOCONF_VER= 253
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502102
-BROKEN= "Does not compile"
-.endif
-
pre-configure:
@cd ${WRKDIR}/${DISTNAME} ; ${AUTOCONF}
@@ -45,4 +41,4 @@ pre-patch:
pre-build:
@${REINPLACE_CMD} -e 's|f2c.h|g2c.h|g;' ${WRKSRC}/miniMOPAC/*.c
@${REINPLACE_CMD} -e 's|f2c.h|g2c.h|g;' ${WRKSRC}/src/common/qm1e_mopac.cpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>