aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/qcl/Makefile4
-rw-r--r--science/vis5d+/Makefile12
2 files changed, 8 insertions, 8 deletions
diff --git a/science/qcl/Makefile b/science/qcl/Makefile
index b8b40edb2f35..235d9f8faf2f 100644
--- a/science/qcl/Makefile
+++ b/science/qcl/Makefile
@@ -14,14 +14,14 @@ EXTRACT_SUFX= .tgz
MAINTAINER= huntting@glarp.com
COMMENT= A quantum computer simulator
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile (bad C++ code)"
.endif
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
post-install:
strip ${PREFIX}/bin/qcl
diff --git a/science/vis5d+/Makefile b/science/vis5d+/Makefile
index 0a6aabe68f71..0823c19e9bcf 100644
--- a/science/vis5d+/Makefile
+++ b/science/vis5d+/Makefile
@@ -16,12 +16,6 @@ MASTER_SITE_SUBDIR= vis5d
MAINTAINER= ports@FreeBSD.org
COMMENT= An OpenGL-based volumetric visualization program for scientific datasets
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
BUILD_DEPENDS= ${LOCALBASE}/lib/libmix.a:${PORTSDIR}/graphics/qslim \
convert:${PORTSDIR}/graphics/ImageMagick
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
@@ -41,4 +35,10 @@ INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_FLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
.include <bsd.port.post.mk>