aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/cdo/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index a07e10c58f63..2670df8ec841 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -16,6 +16,8 @@ LICENSE= GPLv2
OPTIONS_DEFINE= CGRIBEX HDF5 JASPER NETCDF PROJ SZIP UDUNITS
OPTIONS_DEFAULT=CGRIBEX HDF5 JASPER NETCDF PROJ SZIP UDUNITS
OPTIONS_SUB= yes
+HDF5_IMPLIES= SZIP
+NETCDF_IMPLIES= HDF5
PORTSCOUT= site:https://code.zmaw.de/projects/cdo/files
@@ -55,16 +57,6 @@ UDUNITS_CONFIGURE_OFF= --without-udunits2
UDUNITS_CONFIGURE_ON= --with-udunits2=${LOCALBASE}
UDUNITS_LIB_DEPENDS= libudunits2.so:${PORTSDIR}/science/udunits
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MHDF5} && !${PORT_OPTIONS:MSZIP}
-IGNORE= HDF5 option requires SZIP option
-.endif
-
-.if ${PORT_OPTIONS:MNETCDF} && !${PORT_OPTIONS:MHDF5}
-IGNORE= NETCDF option requires HDF5 option
-.endif
-
.include <bsd.port.pre.mk>
.if ${ARCH} != "sparc64"